KDE4 ?

Ken Moffat zarniwhoop at ntlworld.com
Mon Apr 20 15:38:09 PDT 2009


On Mon, Apr 20, 2009 at 07:16:07PM +0200, Nicolas FRANCOIS wrote:
> Hi.
> 
> I'd like to start a new LFS system, but one of my motivations (apart from
> having up to date libs) is KDE4 (and Xorg 7.4, and VLC...).
> 
> I didn't see anything on the LFS site, nor on the CBLFS site, so I'm
> asking the list : is there a sufficiently precise set of instructions for
> compiling this big project ? Is it stable enough for a personnal computer
> (not a production machine... well, sort of... production for my work :-)
> 
> Thanks for any clue.
> 
> \bye
> 
 Apart from what's been mentioned in earlier replies, I've offered a
few updated comments (not sure if they were on -dev or -support, but
they're in the list archives).  The one thing perhaps worth
repeating is that poppler needs to be built _after_ qt.  Maybe I
ought to add that you'll need a _lot_ of space for qt - I think
Bruce put most of the options into the book, but you could check my
comments in the closed ticket for qt4.

 The more I've touched kde4, the more it exasperates me: for the
problem-set I care about, cmake is horrible.  Cmake is also
intrinsically horrible.  I loathe static libraries, maybe you don't
- if you share that view, see the tickets for cmake and xmlrpc-c.

 The current problems I see with kde are: increasingly massive,
build-time dependency on strigi (see the archives if you're tempted
to _run_ strigi), akonadi needs mysql for kmail, kde demands you
build additional functionality if certain packages are found (last
tested in 4.2.1 - gwenview demanded extra packages because 1 was
present, now I just patch a file to edit gwenview out).

 Also, some of the "tools" have to either be pulled out of svn, or
grabbed from a convenient distro.  Last time I looked,
qimageblitz-0.5 source tarball was an the Arch repo, the other tools
seem to now have releases.

 If you want to build _all_ of kde, consult b-vol's notes - he's got
a lot of things in there that I've never even heard of.  I'm now
restricting myself to the tools, base (all 3 parts, base itself
without gwenview!), graphics, multimedia.  For anything more than
that, you _will_ need [ /me chews on raw garlic as protection from
vampires ;-) ] akonadi, which _seems_ to need _static_ boost libs :
for me, in 4.2.1 it found boost but didn't find any libs.

 The base-graphics-multimedia packages seem to work well now.

 I was thinking of not building these so often, and then tonight I
downloaded a PDF where evince (2.24) didn't manage to show the
photos or text - okular was ok.

 I've a feeling some of this stuff (maybe it's only Qt) still looks
in /usr/X11R6 - I put xorg and almost everything else I build into
/usr, so this isn't a problem for me.  If you put xorg somewhere
else, you will probably have more work to do.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list