OO-3.0.1 how to compile

lux-integ lux-integ at btconnect.com
Mon Apr 20 13:49:23 PDT 2009


Greetings,

I have never compiled openoffice  and decided to give the latest version 3.0.1   
a try.  The host runs AMD64-64bit cblfs  (gcc4.3.2, kernel-2.6.27.7).  I 
downloaded all the sources  and reached the stage  where the    configure 
script did not complain  about missing dependencies.  The bottom of the 
output is shown below:-

##############
checking 
DBUS_CFLAGS... -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/opt/include/glib-2.0 -I/opt/lib/glib-2.0/include  
checking 
DBUS_LIBS... -L/opt/lib -ldbus-glib-1 -ldbus-1 -lgobject-2.0 -lglib-2.0  
checking whether to enable GIO support... no
checking whether to enable the cairo canvas backend... yes
checking whether Xrender.h defines PictStandardA8... yes
checking which cairo to use... external
checking for cairo >= 1.0.2 ... yes
checking 
CAIRO_CFLAGS... -I/usr/include/freetype2 -I/usr/include/libpng12 -I/opt/include/cairo -I/usr/X11R7.4/include/pixman-1 -I/usr/X11R7.4/include  
checking CAIRO_LIBS... -L/opt/lib -lcairo  
checking whether to build the OGLTrans extension... yes
checking GL/gl.h usability... yes
checking GL/gl.h presence... yes
checking for GL/gl.h... yes
checking for main in -lGL... yes
checking for main in -lGLU... yes
checking whether to build the Presentation Minimizer extension... yes
checking whether to build the Presenter Console extension... yes
checking whether to build the PDF Import extension... yes
checking for xpdf module... OK
checking for sdext module... OK
checking whether to build the Wiki Publisher extension... yes
checking for swext module... OK
checking which Apache commons-* libs to use... internal
checking which Servlet API Jar to use... internal
checking whether to build the Report Builder extension... yes
checking for reportbuilder module... OK
checking which jfreereport libs to use... internal
checking for jfreereport module... OK
checking for Qt headers... /opt/qt-3.3.8b/include
checking for Qt libraries... /opt/qt-3.3.8b/lib
checking for moc... /opt/qt-3.3.8b/bin/moc
checking for KDE headers... /opt/kde-4.2.1/include
checking for KDE libraries... /opt/kde-4.2.1/lib
checking whether to enable the lockdown pieces... yes
checking whether to enable evolution 2 support... no
checking whether to enable KDE address book support... no
checking whether to include FontOOo... no
checking whether to include MathMLDTD... no
checking whether to include Bitstream Vera fonts... yes
checking whether to include PPDs... yes
checking whether to include AFMs... yes
checking whether to include writer2latex... yes
checking whether and how to use Xinerama... yes, with dynamic linking
checking X11/extensions/Xinerama.h usability... yes
checking X11/extensions/Xinerama.h presence... yes
checking for X11/extensions/Xinerama.h... yes
checking for XineramaIsActive in -lXinerama... yes
checking for jakarta-ant... no
checking for ant... /opt/ant-1.7.0/bin/ant
checking whether ant is >= 1.7.0... yes, 1.7.0
checking if /opt/ant-1.7.0/bin/ant works... Ant works
checking Ant lib directory... Ant lib directory found.
checking whether ant supports mapper type="regexp"... yes
checking which languages to be built... ALL
checking which languages have poor help localizations... none
checking which dictionaries to include... ALL
checking for additional 'intro' bitmaps... none
checking for additional 'about' bitmaps... none
checking for vendor... XXX
checking for UNIX wrapper name... oofice
checking whether to statically link to Gtk... no
checking whether to use layout dialogs... no
checking build verbosity... not set
********************************************************************
*                                                                  *
*   Setting up the build environment variables.                    *
*                                                                  *
********************************************************************
checking solver path... default
configure: creating ./config.status
config.status: creating set_soenv

Test Complete
No environment file will be generated

There were no warnings

################################
however there appears to be no Makefile  nor bootstrap.sh

./bootstrap: No such file or directory
LinuxX86-64Env.Set.sh: No such file or directory


help would be apreciated


yours sincerely
lux-integ
 



More information about the blfs-support mailing list