Upgrading Xorg 7.2 -> 7.4: font problems

Ken Moffat ken at linuxfromscratch.org
Sat Apr 18 18:23:41 PDT 2009


On Sun, Apr 19, 2009 at 01:01:38AM +0100, Jeremy Henty wrote:
> On Sun, Apr 19, 2009 at 12:31:02AM +0100, Ken Moffat wrote:
> 
> > First, you don't tell us which windowmanager you are using.
> 
> Sorry.  I'm using icewm.
 Ah, a man of tast ;-)
> 
> > Second, I understand  what menus are, but what  specifically is "and
> > such like" - it clearly  isn't text _within_ applications, but is it
> > text on the "panel", or in the window titles, or something else ?
> 
> Stuff that is affected:
>   - Icewm right-button menu
>   - Icewm dialogs
>   - text on the buttons in the icewm taskbar
>   - icewm window titles
>   - GUI widget text in applications, *except* FLTK applications
 Odd, all of these work for me (icewm-1.3.3).

 I tried to strace 'startx' to look for any references to fonts, but
there weren't any.  With strace -f or -ff 'startx' isn't able to
write to /var/log.
> 
> Stuff that is not affected:
>   - FLTK widgets
>   - the main window of rxvt (terminal emulator)
>   - web pages in Firefox

 I don't have any FLTK things here.  Urxvt works (with truetype
fonts), but so does everything else.
> 
> I have the DejaVu fonts installed.  They show up nicely in fc-list and
> they are what Firefox uses for web page text.
> 
> > You  are upgrading  an old  system,  I think.   Have you  *upgraded*
> > freetype, fontconfig, and cairo ?
> 
> I have kept everything  pretty up-to-date except Xorg itself.  Current
> versions are:
> 
>    cairo-1.8.6
>    pango-1.22.4
>    fontconfig-2.6.0
>    freetype-2.3.9

 I'm on freetype-2.3.7.  Don't have time to keep track of
everything, but 2.3.9 looks like a mandatory upgrade if you were on
2.3.9.
> 
> None of these had any problems  running against Xorg 7.2 (not even the
> famously hairy freetype upgrade broke anything).
> 
> I tried switching  to Xorg 7.4 but linking the  font directory back to
> the Xorg  7.2 fonts.  That didn't  fix anything, so it's  not that the
> fonts themselves  are broken  (or at least  it's not just  that).  The
> text looks as  though it's been rendered at  a ludicrously small size,
> though I can't be sure that is actually what has gone wrong.
> 

 Ah.  I thought you just had "random smears of pixels".
> Re-running mkfontdir  and mkfontscale in  all the font  directories in
> lib/X11/fonts hasn't helped either.

 I've dropped the old core fonts with --enable-builtin-fonts in the
xserver (1.5.3) : not very nice for the division symbol in xcalc, no
other problems I've noticed - and I just put the fonts there and let
it work.  I've got various TTF directories (dejavu etc)
in /usr/share/fonts plus a /usr/share/fonts/X11-TTF symlink to a
non-existent /usr/lib/X11/fonts/ttf.  I guess you can say I've
stopped worrying about the fonts.

 So, what is different for you ?  When you say the text looks as if
it has been rendered at a ludicrously small size, I wonder about
xorg-server (ISTR a previous lost the dpi information, but I could
be mistaken, and anyway I think you said you were using 1.5.3).  The
other obvious candidate is freetype, even though it was working with
7.2.  Dunno.  I try to keep my systems in use for longer nowadays,
but I haven't upgraded xorg on a working system for a bit over a
year (and that was only because I had problems with the radeon
driver on a mac ppc).

 Sorry, this isn't very helpful.

ĸen



 
> 
> Regards,
> 
> Jeremy Henty
> -- 
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page

-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list