kdewebdev-4.2.x and ruby

lux-integ lux-integ at btconnect.com
Wed Apr 8 18:31:38 PDT 2009


On Wednesday 08 April 2009 07:12:08 pm Agathoklis D. Hatzimanikas wrote:
> On Wed, Apr 08, at 06:28 lux-integ wrote:
> > Greetings,
> >
> > I am using a pure 64-bit (AMD64) cblfs-linux box  to build kde4  from
> > sources. I am trying to compile  kdewebdev-4.2.1/4.2.2.  After the cmake
> > command,  it complains that ruby is absent.  I installed ruby in   /usr
> >  (libraries in /usr/lib/ruby,  headers in /usr/include/ruby-1.9.1)  It
> > still fails to fund ruby.  I even edit  CMakelists.txt  and inserted
> > /usr/include/ruby-1.9.1 in the  line for 'include_headers'.  This still
> > made no difference.
> >
> > I would be grateful for some guidance on   any links that need to be made
> > that   allows ruby to be seen by cmake.
>
> I would recommend you to go with Ruby-1.8.* as the most applications are
> still not 1.9.* aware (they might work but quite probably they won't).
>
> In a related note, in 1.9.* the location of the installed headers had
> changed in such way that is a little bit harder for applications to find
> them during initial configuration and use them during compilation.
>
> In any case if you want to proceed with the 1.9 branch you can use
> something like:
>
> cmake CXXFLAGS="${CXXFLAGS} -I/usr/include/ruby-1.9.1/     \
>                    -I/usr/include/ruby-1.9.1/i686-linux/"  \
>               CFLAGS="${CFLAGS} -I/usr/include/ruby-1.9.1/ \
>                    -I/usr/include/ruby-1.9.1/i686-linux/"
>
I tried the above   after cmake and even edited CMakeLists.txt  all to no 
avail.    I then cleaned-out ruby-1.9.1 (bin,lib,include) and installed 
ruby-1.8.7-p22  and still cmake refuses to budge.

Thanks for your suggestion,  I will keep trying till I get lucky.

>
> Regards,
> Ag.





More information about the blfs-support mailing list