Swapon not working

Lauri Kasanen curaga at operamail.com
Fri Oct 31 12:32:49 PDT 2008


> Hi
> 
> I've managed without a swap partition until now, but  I'm trying to
> build open office and the build is failing at the last minute due to
> lack of memory.  So now I've made a swap partition of 2 gig and run
> mkswap.  I've also amended the fstab.  All seems fine until I run swapon
> -a which returns "Function not implemented".
> 
> I've tried making a swap file rather than a partition but I get the same
> output. If I reboot to run the script at boot-time I can see the same
> output.  I've tried various sizes of swap -- no difference.  Could it be
> a udev problem?  I upgraded to udev-124 some time ago but everything
> else works fine.  Running "free -m" shows swap but with all zeros, of
> course.  Maybe "swapon" is corrupted -- I just don't know.  I have no
> /proc/swaps file.  When is this generated?  I was wondering whether swap
> has to be enabled in the kernel but I can find no reference to it in the
> kernel .config.
> 
> I'd be really grateful for some help as I'm right at the final stage of
> my BLFS build.
> 
> Richard

Hello, this really does sound like it isn't enabled in your kernel.
The option is CONFIG_SWAP, or under the name "Support for paging of anonymous memory (swap)".

Hope I could help.

Lauri

-- 
_______________________________________________
Surf the Web in a faster, safer and easier way:
Download Opera 9 at http://www.opera.com

Powered by Outblaze



More information about the blfs-support mailing list