Xorg Fatal error Could not load default font 'fixed'

Ken Moffat zarniwhoop at ntlworld.com
Sat Oct 25 13:56:10 PDT 2008


On Sat, Oct 25, 2008 at 04:22:24PM +0530, jignesh gangani wrote:
> Dear All,
> 
> I know this is a known problem, but none of the solution work for me.
> 
> 
> I am building Xorg-7.2 and I have installed the fonts in required
> order. (encodings, font-utils,
> font-misc-misc, font-cursorgen). Firstly, I forgot to install
> font-alias package. But even after
> installing the font-alias package, I still get the same error. I
> checked the fonts.alias file in
> /usr/share/fonts/misc/. It does contain 'fixed' font alias and points to some
> -misc-normal-semicondensed-..... file, which when I checked in
> fonts.dir points to 9x13-IS08859-1.
> And that file exists in /usr/share/fonts/misc. Then why does the X
> server giving me the error?
> I have checked and there is no other error in /var/log/Xorg.log.0. The
> xorg.conf.new contains correct
> font paths (/usr/share/fonts/) and in correct order (first comes
> 'misc' then others).
> 
> Some suggest that to start xfs, but in {C}BLFS, xfs is not started
> explicitly AFAIK. So xfs is
> not an issue. Then can any body explain what the problem is?
> 
 Up until now, I've always installed either font-adobe-75dpi (for
small screens) or font-adobe-100dpi (for large screens).  You could
try adding one of those and seeing if it helps.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list