Jasper (jpeg-2000)

Ken Moffat ken at linuxfromscratch.org
Sat Oct 4 12:55:14 PDT 2008


On Sat, Oct 04, 2008 at 10:48:49PM +1300, Simon Geard wrote:
> On Fri, 2008-10-03 at 12:46 +0100, Ken Moffat wrote:
> > I built gtk+-2.14.3 last night, and was more than a little surprised
> > to find that it now expects jasper (or, failing that,
> > --without-libjasper ) the configure output is very helpful, but I
> > had assumed jpeg2000 was another thing that hardly anybody used.
> 
> No it doesn't. I'm running 2.14.3, and I've never heard of Jasper -
> certainly, I didn't need to do anything special to build without it...
> 
> Simon.

 Odd.  I'm on a different machine at the moment, so I can't expect
it to build with the old versions, but with

 ./configure --prefix=/usr --sysconfdir=/etc --disable-static

 it stopped and I found the reference to jasper in the log.  That
was on x86_64, although I very much doubt that makes any
difference.

 the configure help includes
  --with-gdktarget=[x11/win32/quartz/directfb] select non-default GDK target
  --without-libpng        disable PNG loader for gdk-pixbuf
  --without-libjpeg       disable JPEG loader for gdk-pixbuf
  --without-libtiff       disable TIFF loader for gdk-pixbuf
  --without-libjasper     disable JPEG2000 loader for gdk-pixbuf
  --with-included-loaders=LOADER1,LOADER2,...
                          build the specified loaders into gdk-pixbuf

 and at line 29010 is

  if test x$with_libjasper != xno && test -z "$LIBJASPER"; then
     { { $as_echo "$as_me:$LINENO: error:
*** Checks for JPEG2000 loader failed. You can build without it by passing
*** --without-libjasper to configure" >&5
$as_echo "$as_me: error:
*** Checks for JPEG2000 loader failed. You can build without it by passing
*** --without-libjasper to configure" >&2;}
   { (exit 1); exit 1; }; }
  fi

ĸen


-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list