Firefox fails only with external NSS

Karel Kulhavy twibright at hispeed.ch
Sun Feb 24 23:25:16 PST 2008


I tried to compile Firefox 1.5.0.9 on my freshly installed box with LFS 6.3, BLFS 6.2,
Core 2 Duo and GCC 4.1.2.

If I follow the instructions with external NSS and without Pango, I get 
In file included from /home/clock/mozilla/security/manager/ssl/src/nsCipherInfo.h:40,
                 from /home/clock/mozilla/security/manager/ssl/src/nsCipherInfo.cpp:38:
../../../../dist/include/system_wrappers/sslt.h:3:23: error: sslt.h: No such file or directory

And a lot of similar errors. They are caused by "sslt.h" being included instead of "nss/sslt.h". If I start repairing these manually, they go away but there are always many many more. I just gave up repairing them.

To prevent a bogus report, I:
* tried it several times with a fresh tree to make sure I didn't make a mistake
* checked I applied the NSS patch
* checked I uncommented the NSS/NSPR in the .mozconfig
* made sure there is no -j flag to the make

But I still had CFLAGS and CXXFLAGS set to "-O3 -march=pentium-m -fomit-frame-pointer". I think these flags should have no effect on include files. Or do you think I should try once more without these optimization flags?

If I try with internal NSS, it compiles and runs.

CL<



More information about the blfs-support mailing list