Fwd: Xorg7.4-installation-xcursor-themes-1.0.1 compile problems

b-vol lux-integ at btconnect.com
Tue Dec 9 08:22:13 PST 2008


On Tuesday 09 December 2008 03:57:28 pm Ken Moffat wrote:
> On Tue, Dec 09, 2008 at 10:56:59AM +0000, b-vol wrote:
> > Greetings,
> >
> > I am having a spot of bother with cursor-themes-1.0.1 compilation.  I
> > have installed the rest of Xorg7.4  (including Xserver-1.5.3) without
> > problems. The fonts need x-cursor-themes-1.0.1 and this is proving  
> > problematic to compile. The problem is described in the two snippets
> > below.
> >
> > ###   after  configure and  make is executed:- ##########
> > /usr/X11R7.4/bin/xcursorgen -p ../redglass ./X_cursor.cfg X_cursor
> > /usr/X11R7.4/bin/xcursorgen: error while loading shared libraries:
> > libX11.so.6: cannot open shared object file: No such file or director
>
>  Is this a multilib system ?  That message looks like what you might
> get if one of the items is built 32-bit and the other is built
> 64-bit.
>
> > ########but ls returns libX11.so.6  in /usr/X11R7.4/lib:- #########
> > bash-3.2# ls  -l  /usr/X11R7.4/lib/libX11.so.6
> > lrwxrwxrwx 1 root root 15 2008-12-08 12:03 /usr/X11R7.4/lib/libX11.so.6
> > -> libX11.so.6.2.0
> > bash-3.2#
> >
> > helpful suggestions will be appreciated
>
>  Try ldd /usr/X11R7.4/lib/libX11.so.6 ?
>
> ĸen
> --
> das eine Mal als Tragödie, das andere Mal als Farce

I checked /etc/ld.so.cong and I had forgotton  to put an entry 
for /usr/X11R7.4.
I have done the fix and all's well.

thanks for your help.

-- 

###################################
“Common sense teaches that booksellers should not speculate in hops, 
or bankers in turpentine; that railways should not be promoted by maiden 
ladies, or canals by beneficed clergymen ....”
Walter Bagehot-economist: 1826-1877 



More information about the blfs-support mailing list