GDM install error

Randy McMurchy randy at linuxfromscratch.org
Tue Dec 2 07:58:45 PST 2008


v4mpire at chaoticnetworks.com wrote:

> I was actually installing without scrollkeeper and was using
> --disable-scrollkeeper which allowed configure to run through and the
> error was the same on the book version of 2.18.3 and 2.18.4 so seems even
> tho scrollkeeper is optional on some stages it really isn't on gdm even
> though you can disable it and on gdm itself it doesn't state it needs
> scrollkeeper on the book anyway but in configure it does, guess i'll go
> give it a try with scrollkeeper installed

Replying for the archives, as I want to clarify how the
dependencies work.

Actually, following the BLFS book, ScrollKeeper is not optional.
It is a recommended dependency of GNOME Doc Utils which is
required for GDM. There is even a note attached to the GDU
instructions that says you *can* install GDU without ScrollKeeper
but you will be missing required functionality.

So, the BLFS staff expects ScrollKeeper to be installed when you
begin the installation of GDM. Dependencies (required by another
dependency) are not mentioned again for the sake of redundancy.

Hopefully, this clarifies the issue of "on gdm itself it doesn't
state it needs scrollkeeper on the book anyway but in configure it
does".

-- 
Randy



More information about the blfs-support mailing list