GDM install error

Ken Moffat ken at linuxfromscratch.org
Tue Dec 2 07:17:52 PST 2008


On Tue, Dec 02, 2008 at 02:20:35PM -0000, v4mpire at chaoticnetworks.com wrote:
> 
> Hey all,
> 
> I have tryed a few versions of gdm with same error and cant find a result
> anywhere so hope you guys can help... this is the error im getting...
> 
> ake[4]: Entering directory `/home/v4mpire/gdm-2.19.1/docs/de'
> /bin/sh ../../mkinstalldirs /usr/share/omf/gdm
> for file in gdm-de.omf; do \
>                 /usr/bin/install -c -m 644 $file.out
> /usr/share/omf/gdm/$file; \
>         done
> /usr/bin/install: cannot stat `gdm-de.omf.out': No such file or directory
> make[4]: *** [install-data-hook-omf] Error 1
> make[4]: Leaving directory `/home/v4mpire/gdm-2.19.1/docs/de'
> make[3]: *** [install-data-am] Error 2
> make[3]: Leaving directory `/home/v4mpire/gdm-2.19.1/docs/de'
> make[2]: *** [install-am] Error 2
> make[2]: Leaving directory `/home/v4mpire/gdm-2.19.1/docs/de'
> make[1]: *** [install-recursive] Error 1
> make[1]: Leaving directory `/home/v4mpire/gdm-2.19.1/docs'
> make: *** [install-recursive] Error 1
> 
> hope to hear back from someone on how to fix.
> 
> Cheers,
> 
> Gary
> 
 First, don't build odd-numbered gnome versions (e.g. 2.19) -
unless, of course, you are testing gnome-development (but then, you
wouldn't be using 2.19).

 I happen to be using gdm-2.18.4 (as previously reported, I loathe
the behaviour of gdm-2.{20,22} when I shut down, and I gave up adding
dependencies to build 2.24, there were just too many things I don't
want to use).  For 2.18.4, my logs show gdm-de.omf is referenced
twice, the first of which created the .out version:

make[3]: Entering directory `/usr/src/gdm-2.18.4/docs/de'
for file in gdm-de.omf; do \
          scrollkeeper-preinstall
/usr/share/gnome/help/gdm/de/gdm.xml ./$file $file.out; \
        done; \
        touch omf_timestamp
make[3]: Leaving directory `/usr/src/gdm-2.18.4/docs/de'

 I imagine 2.19.1 will be pretty similar for this.  So, either you
are missing scrioolkeeper, and/or your build system failed to report
an error.  Looking a bit further in my log, I will guess that the
Makefile is not concerned about xml failures -

 In 2.18.4 this is the first of several translations.  I now see
that my 'make' reported undefined entities (% and —)
for zh_TW, es, uk but those didn't prevent the build or install and
anyway I can't read Taiwanese, Spanish, or Ukrainian.

 If you are on BLFS-6.3, the versions in the book should work.  If
you aren't, use the series which matches the rest of your gnome
build.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list