DVD Playback problems

Shawn sks at shaw.ca
Thu Feb 22 21:08:48 PST 2007


On February 22, 2007, Nik Davis wrote:
> On 2/22/07, Dan Nicholson <dbn.lists at gmail.com> wrote:
> > On 2/22/07, Nik Davis <nerostar450 at gmail.com> wrote:
> > > I'm having trouble getting my DVD playback to work correctly.  I
> > > have
> >
> > the
> >
> > > symlink /dev/dvd set up, and I can open a DVD (using VLC,
> > > MPlayer, etc)
> >
> > but
> >
> > > the DVD will be out of sequence or play correctly but without
> > > sound etc. Any ideas?
> >
> > I don't know what etc. means, but do you get normal sound playback?
> > Can you do speaker-test and get output? If the DVD is playing, then
> > it sounds like you've gotten past any issues with /dev/dvd and the
> > like. I don't use VLC or MPlayer much, but you can see if there's a
> > --verbose switch or the something. Maybe it'll give you more
> > information about what's going on.
> >
> > --
> > Dan
> > --
> > http://linuxfromscratch.org/mailman/listinfo/blfs-support
> > FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> > Unsubscribe: See the above information page
>
> One DVD I tried plays sound fine but plays the commentary by default.
> Another does nothing but buzz loudly, but if I start in the second
> chapter, plays fine.  Some play sound fine, but don't start at the
> beginning of the DVD.  Here is the output from MPlayer on the one one
> that just buzzes loudly:
>
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> MPlayer 1.0pre7try2-4.0.3 (C) 2000-2005 MPlayer Team
> CPU: Advanced Micro Devices Athlon MP/XP/XP-M Barton (Family: 6,
> Stepping: 0)
> Detected cache-line size is 64 bytes
> CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
> Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE
>
>
> 85 audio & 196 video codecs
> Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
> Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your

Did you try the above? I believe it is a requirement for mplayer.
Shawn

> system startup scripts.
> Playing dvd://1.
> Reading disc structure, please wait...
> There are 21 titles on this DVD.
> There are 37 chapters in this DVD title.
> There are 1 angles in this DVD title.
> DVD successfully opened.
> MPEG-PS file format detected.
> VIDEO:  MPEG2  720x480  (aspect 3)  29.970 fps  9800.0 kbps (1225.0
> kbyte/s)
> =====================================================================
>===== Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
> Cannot find codec 'dts' in libavcodec...
> ADecoder init failed :(
> ADecoder init failed :(
> Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF
> No accelerated IMDCT transform found
> hwac3: switched to DTS, 768000 bps, 48000 Hz
> AUDIO: 48000 Hz, 2 ch, ac3, 768.0 kbit/50.00% (ratio: 96000->192000)
> Selected audio codec: [hwdts] afm:hwac3 (DTS through S/PDIF)
> =====================================================================
>===== vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" =>
> local display)
> =====================================================================
>===== Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
> VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)
> Could not find matching colorspace - retrying with -vf scale...
> Opening video filter: [scale]
> The selected video_out device is incompatible with this codec.
> VDecoder init failed :(
> Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder
> libmpeg2-v0.4.0b Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG-1
> or 2 (libmpeg2))
> =====================================================================
>===== Checking audio filter chain for 48000Hz/2ch/ac3 ->
> 48000Hz/2ch/ac3... AF_pre: 48000Hz/2ch/ac3
> [AO OSS] Can't set audio device /dev/dsp to ac3 output, trying
> s16le... AO: [oss] 48000Hz 2ch s16le (2 bps)
> Building audio filter chain for 48000Hz/2ch/ac3 ->
> 48000Hz/2ch/s16le... [format] Sample format big-endian AC3 not yet
> supported
> [libaf] Reinitialization did not work, audio filter 'format' returned
> error code -2
> Couldn't find matching filter/ao format!
> Starting playback...
> VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
> VDec: using Planar YV12 as output csp (no 0)
> Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
> VO: [xv] 720x480 => 854x480 Planar YV12
> A:   0.7 V:   0.7 A-V: -0.000 ct:  0.028  16/ 13 ??% ??% ??,?% 0 0
> demux_mpg: 24000/1001fps progressive NTSC content detected, switching
> framerate.
> A:   1.8 V:   1.8 A-V:  0.002 ct:  0.050  43/ 40  9%  3%  0.5% 0 0
>
> MPlayer interrupted by signal 15 in module: sleep_timer





More information about the blfs-support mailing list