a problem:when configuring Glibc-2.3.6

Ken Moffat ken at linuxfromscratch.org
Fri Apr 27 18:13:18 PDT 2007


On Fri, Apr 27, 2007 at 06:36:00PM +0800, Xudong Du wrote:
> error: these critical programs are missing or too old: ld
> this error occurs when configure the Glibc-2.3.6 in chapter 6 of LFS 6.2 and
> no makefile made due to the error.
> could you please tell me what's wrong with it?
> and what should I do?
> thanks a lot!

 A strange error (assuming, of course, that you haven't built a
different version of binutils than what is in the book).

 The first question has to be: is ld actually missing, or does it
think it's too old?  Somewhere in the build directory (or maybe in
one of its subdirectories) you should have a config.log which shows
the details (code, results) for the relevant test (you may also have
other config.log files).  Please share the results of the test
(particularly any error messages) with us.  Possibly, the error
message(s) will point to the problem (e.g. perhaps one of the
libgcc_s symlinks is missing, which causes gcc to fail to compile,
and the test which triggers that is looking for the version of ld).

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-support mailing list