Increase LOG Level of startup of Xorg

Dan Nicholson dbn.lists at gmail.com
Fri Apr 20 09:18:47 PDT 2007


On 4/20/07, Michael Chalvatzis <glykos at gmx.net> wrote:
> Dan Nicholson <dbn.lists <at> gmail.com> writes:
> >
> > Can you attach Xorg.log? Look for messages that begin with (EE).
>
> thanks for your reply. I will attach the output of the Xorg.log, when I will be
> back at home. Currently my progress in BLFS is very slow as I have to do many
> other things in parallel.
> BTW: I have a short update of my yesterday's investigation:
> I compiled a new kernel (2.6.20.7; radeon DRI and DRM enabled in the kernel) and
> now I do not get any (EE)'s at all. But now the symptoms look different.
> Starting {Xorg, xinit, start} leaves just a blank black screen without the
> typical X root window and then the final crash :-(.

That's too bad. Is there any output at the end of Xorg.log the next
time you start the machine (before starting X again)?

> My suggestion is right now that the switch from the frame buffer console to X
> windows does not work. The curious thing on the other hand is that if I boot
> from the LFSISO CD, the X-windows runs with the "ati" driver. So the only
> difference that I can see is that the CD starts without switching into the
> FB-mode in the console.
> May this be my problem?

Yes. Interaction between the X drivers and the kernel FB drivers is
notoriously bad,  radeon included. I have a Radeon 9250 in one of my
boxes and had issues using radeonfb with X. I ended up disabling it
and just using the vesa kernel FB module. It does what I need it to do
and hasn't caused any problems since.

> I didn't had enough time to test this issue, but maybe someone else knows some
> incompatibilties between framebuffer and x-graphics with the "ati" or radeon
> driver (kernel and X)

Which model ATI card is this?

--
Dan



More information about the blfs-support mailing list