Increase LOG Level of startup of Xorg

Michael Chalvatzis glykos at gmx.net
Fri Apr 20 02:05:53 PDT 2007


Dan Nicholson <dbn.lists <at> gmail.com> writes:

> 
> This may not work in your case, but if you have two machines, you may
> be able to ssh into the frozen box and kill X. Doesn't always work,
> but sometimes.
> 
> 
> Can you attach Xorg.log? Look for messages that begin with (EE).
> 
> --
> Dan

Hi Dan,

thanks for your reply. I will attach the output of the Xorg.log, when I will be
back at home. Currently my progress in BLFS is very slow as I have to do many
other things in parallel. 
BTW: I have a short update of my yesterday's investigation:
I compiled a new kernel (2.6.20.7; radeon DRI and DRM enabled in the kernel) and
now I do not get any (EE)'s at all. But now the symptoms look different.
Starting {Xorg, xinit, start} leaves just a blank black screen without the
typical X root window and then the final crash :-(.
My suggestion is right now that the switch from the frame buffer console to X
windows does not work. The curious thing on the other hand is that if I boot
from the LFSISO CD, the X-windows runs with the "ati" driver. So the only
difference that I can see is that the CD starts without switching into the
FB-mode in the console.
May this be my problem?
I didn't had enough time to test this issue, but maybe someone else knows some
incompatibilties between framebuffer and x-graphics with the "ati" or radeon
driver (kernel and X)

More details when I'm at home (sooner or later..)

Thanks, Michael




More information about the blfs-support mailing list