Upgrade Kernel to 2.6.20.x Problem

Jeffrey Bush bushj at rpi.edu
Tue Apr 10 11:13:55 PDT 2007


> I just installed the latest LFS (version 6.2) completely and installed 
> many BLFS programs. The LFS book is designed to install Linux kernel 
> version 2.6.16.x. After getting this far I found out that the newest 
> kernel supports graphics drivers for my graphics card and 2.6.16 does not.
>
> ...I tried just downloading the 
> source code for the newest stable kernel, and set all the options like 
> I did previously, compiled, copied, and modified /boot/grub/menu.lst.
>
> Along came a problem. Now doing bootup it says:
> "Kernel Panic: not syncing: VFS: Unable to mount root fs on 
> unknown-block(0,0)"
>
> The hard drive detection information is way off the screen and scrolls 
> by too fast so I cannot see it. I have tried enabling scrolling for it 
> but it does not seem to work. I have tried installing just the PATA 
> and SATA drivers for my mobo and also tried all SATA and PATA drivers 
> without luck. I have installed all of the appropriate filesystem 
> drivers (Ext3). Still no luck. Is there something else I need to 
> enable? I have tried doing
> root=/dev/xxx1 with every combination I thought possible for xxx (hdx 
> and sdx). I have also tried playing around with using the root=0xXXX 
> stuff with no luck.
>
>
>
> Do I need to update the installed kernel headers? There are only a few 
> warning compile messages, no errors. If I update the installed kernel 
> headers does it mean that I have to also reinstall any software that 
> used them? Should I just start over?
>
>
>
> Luckily I made sure to keep the other kernel around and am now dual 
> booting the two. Is it alright to have their System.map-2.6.x.x, 
> config-2.6.x.x and kernel images in the same boot folder?
>
>
>
> Thanks in advance,
>
> Jeff


Thanks for everyone's prompt response.

First off, here is the complete message leading up to the Kernel Panic:

VFS: Cannot open root device "hda1" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel Panic: not syncing: VFS: Unable to mount root fs on
unknown-block(0,0)

My current root= is /dev/hda1 which is how it was when I had the original
kernel (2.6.16). I have since tried /dev/hdx1 with x=a-d. I have also tried
/dev/sdx1 with x=a-e because when I use the LFS LiveCD the hard drive shows
up as sda1.

I cannot get the scrolling to stop. Pressing or holding scroll lock does
nothing. After the message stops I cannot use PgUp/Down, arrows, or anything
to change (including using things with shift, ctrl, or alt).

Seeing that it is unknown-block(0,0) it is most likely not finding the
device at all, as per Simon's suggestion. Also, the warning against
upgrading the kernel pertains to the bootscripts, which are not even being
run because the root drive is not mounted ever. I'll worry about the boot
scripts not working (although it sounds like they will anyways) when I get
there. So it is most likely a SATA driver issue. (I am pretty sure I can see
the message about the CD drive being loaded to hdc).

My current kernel configuration has every single SATA and PATA driver
installed, and I have tried just Intel PIIX/ICH SATA Support (my motherboard
is Intel ICH7M/945GM - M for mobile). I also have ext2 and ext3 filesystem
support installed. None of these are modules.

The Intel Graphics are built in, and I have seen the Linux drivers page for
them, but they said it was complicated to install so I thought it would be
easier to just upgrade the kernel itself...

So, I guess the main thing is, what other options (like in "ATA/ATAPI...
support" or "SCSI device support") should be also enabled or disabled?

Jeff





More information about the blfs-support mailing list