kdegraphics

Alessandro Alocci alessandro.alocci1 at tin.it
Mon Apr 9 13:13:01 PDT 2007


On Monday 09 April 2007 19:47:30 Jorge Almeida wrote:

> >>  	kfile_exr.cpp: In member function 'virtual bool
> >> KExrPlugin::readInfo(KFileMetaInfo&, uint)': kfile_exr.cpp:229: error:
> >> 'hasutcOffset' was not declared in this scope kfile_exr.cpp: At global
> >> scope:
> >>  	kfile_exr.cpp:164: warning: unused parameter 'what'
> >>  	make[3]: *** [kfile_exr.lo] Error 1
> >>  	make[2]: *** [all-recursive] Error 1
> >>  	make[1]: *** [all-recursive] Error 1
> >>  	make: *** [all] Error 2
> >
> > This seems a problem with an OpenEXR header.
> > Can you check if you have installed openexr and what version?
> > If you have it, you should have also
> > $openexr_prefix/include/OpenEXR/ImfStandardAttributes.h
> > (included by kfile_exr.cpp)
> > containing a line like this:
> > IMF_STD_ATTRIBUTE_DEF (utcOffset, utcOffset, float)
>
> Yes, I have OpenEXR 1.5.0, and the file (and line) exists. I have KDE in
> /opt/kde, and OpenEXR in /usr. Running "configure -help" of kdegraphics
> shows there is an option to enable support for OpenEXR, but no option to
> tell where OpenEXR is. So I tried making a symlink
> /opt/kde/include/OpenEXR to /usr/include/OpenEXR and tried again
> (extracting again the tarball). It still fails.

1.5.0 is the latest development version.
I have just downloaded, see this:

alex at clivis /mnt/rh/bld/openexr-1.5.0# diff IlmImf/ImfStandardAttributes.h \
> ../openexr-1.4.0/IlmImf/ImfStandardAttributes.h
64d63
< #include <ImfRationalAttribute.h>
147c146
< IMF_STD_ATTRIBUTE_DEF (utcOffset, UtcOffset, float)
---
> IMF_STD_ATTRIBUTE_DEF (utcOffset, utcOffset, float)

Notice how the second utcOffset is different (U vs. u)
Maybe is a typo, don't know, you can try to correct manually
but perhaps you can also consider to downgrade to the latest
stable version (1.4.0a)
A. Alocci



More information about the blfs-support mailing list