kdegraphics

Jorge Almeida jalmeida at math.ist.utl.pt
Mon Apr 9 10:47:30 PDT 2007


On Mon, 9 Apr 2007, Alessandro Alocci wrote:

> On Monday 09 April 2007 10:39:24 Jorge Almeida wrote:
>> I can't compile kdegraphics-3.5.6. I installed aRts, kdelibs and kdebase.
>> The config command is "DO_NOT_COMPILE="kio_kamera kpovmodeler kooka"
>> ./configure --prefix=/opt/kde --disable-debug
>> --disable-dependency-tracking". Without the DO_NOT_COMPILE variable the
>> problem remains. I also installed the recommended packages and several
>> optional packages.
> (...)
>>  	kfile_exr.cpp: In member function 'virtual bool
>> KExrPlugin::readInfo(KFileMetaInfo&, uint)': kfile_exr.cpp:229: error:
>> 'hasutcOffset' was not declared in this scope kfile_exr.cpp: At global
>> scope:
>>  	kfile_exr.cpp:164: warning: unused parameter 'what'
>>  	make[3]: *** [kfile_exr.lo] Error 1
>>  	make[2]: *** [all-recursive] Error 1
>>  	make[1]: *** [all-recursive] Error 1
>>  	make: *** [all] Error 2
>
> This seems a problem with an OpenEXR header.
> Can you check if you have installed openexr and what version?
> If you have it, you should have also
> $openexr_prefix/include/OpenEXR/ImfStandardAttributes.h
> (included by kfile_exr.cpp)
> containing a line like this:
> IMF_STD_ATTRIBUTE_DEF (utcOffset, utcOffset, float)
>
Yes, I have OpenEXR 1.5.0, and the file (and line) exists. I have KDE in
/opt/kde, and OpenEXR in /usr. Running "configure -help" of kdegraphics
shows there is an option to enable support for OpenEXR, but no option to
tell where OpenEXR is. So I tried making a symlink
/opt/kde/include/OpenEXR to /usr/include/OpenEXR and tried again
(extracting again the tarball). It still fails.

Thanks,

Jorge Almeida



More information about the blfs-support mailing list