ffmpegthumbnailer build error

anirudh vij anirudhvij at gmail.com
Wed Apr 4 09:55:22 PDT 2007


hi,
I am getting this make error(this is needed by thunar's extra thumbnailer
plugin to preview video files).It obvoisly needs an include
file.Howeverthat file does'nt exist in fmpeg include
dir.I have built the blfs version of ffmpeg.i cant get the latest subversion
(college proxy does'nt allow svn :(



moviedecoder.cpp:6:28: error: ffmpeg/swscale.h : No such file or directory
moviedecoder.cpp: In member function 'void MovieDecoder::initializeVideo()':
moviedecoder.cpp:81: error: base operand of '->' has non-pointer type
'AVCodecContext'
moviedecoder.cpp:94: error: cannot convert 'AVCodecContext' to
'AVCodecContext*' in assignment
moviedecoder.cpp:105: error: 'struct AVFormatContext' has no member named
'flags'
moviedecoder.cpp :105: error: 'AVFMT_FLAG_GENPTS' was not declared in this
scope
moviedecoder.cpp: In member function 'void MovieDecoder::seek(int)':
/usr/include/ffmpeg/avformat.h:542: error: too many arguments to function
'int av_seek_frame(AVFormatContext*, int, int64_t)'
moviedecoder.cpp:152: error: at this point in file
moviedecoder.cpp:155: error: cannot convert 'AVCodecContext' to
'AVCodecContext*' for argument '1' to 'void
avcodec_flush_buffers(AVCodecContext*)'
moviedecoder.cpp: In member function 'void
MovieDecoder::convertAndScaleFrame(int, int, int&, int&)':
moviedecoder.cpp:266: error: 'SwsContext' was not declared in this scope
moviedecoder.cpp :266: error: 'scaleContext' was not declared in this scope
moviedecoder.cpp:268: error: 'SWS_BICUBIC' was not declared in this scope
moviedecoder.cpp:268: error: 'sws_getContext' was not declared in this scope

moviedecoder.cpp:272: error: 'sws_freeContext' was not declared in this
scope
moviedecoder.cpp:281: error: 'sws_scale' was not declared in this scope
moviedecoder.cpp:282: error: 'sws_freeContext' was not declared in this
scope
make[1]: *** [moviedecoder.o] Error 1
make[1]: Leaving directory `/home/hackman/ffmpegthumbnailer-1.0/src'
make: *** [all-recursive] Error 1

  ls /usr/include/ffmpeg/
avcodec.h  avformat.h  avio.h  common.h  rational.h  rtp.h  rtsp.h
rtspcodes.h


any ideas?


i have build and installed xfce without this package.There is one strange
problem though.
the TERMINAL terminal emulator that ships with xfce4.2 does not open on
clicking.xterm and everything else works.
vte is installed( without any special tweaking).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20070404/33838c73/attachment.html>


More information about the blfs-support mailing list