Problems with fonts and UIs

Alexander Solano asolanour at comcast.net
Fri Mar 24 11:20:15 PST 2006


Ken Moffat wrote:
> On Fri, 24 Mar 2006, Alexander Solano wrote:
>
>> Alexander Solano wrote:
>>> Installing BLFS SVN 20060321 (LFS SVN 20060322), Xorg 6.9.0
>
>>> Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, 
>>> removing from list!
>>> FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc/" refcount is 2, 
>>> should be 1; fixing.
>
>  Just for the record, those messages seem normal to me!  I only notice 
> the refcount message on my ppc64 because everything else has moved to 
> a graphical login, but I'm sure I've seen them on the other boxes.  It 
> doesn't seem to cause any problems.
>
>  For me, the CID message is expected because I think I stopped 
> building them ages ago - a quick look shows the directory does exist, 
> but only contains fonts.dir and fonts.scale.
>
>  Glad you resolved the problem.
>
> Ken
Good to know those are normal messages... I guess :)

Just want to inform that now the last two lines of the Xorg.0.log are:

Could not init font path element /usr/X11R6/lib/X11/fonts/local, 
removing from list!
FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc:unscaled" refcount is 
2, should be 1; fixing.

... And yes, the /usr/X11R6/lib/X11/fonts/local directory contains only 
a few files, no fonts. The CID directory however contains now all kind 
of font files, and is not part of the Xorg.0.log anymore... Since is 
working I'm just going to quit when I'm ahead and not worry about it.



More information about the blfs-support mailing list