openoffice 2.0.0 compiling problems

Dan Nicholson dbn.lists at gmail.com
Fri Mar 24 09:52:43 PST 2006


On 3/24/06, Nicolas <nicolas.beaubatie at free.fr> wrote:
>
> Making: ../unxlngi6.pro/lib/libvclplug_gen680li.so
> g++ -Wl,-z,combreloc -Wl,-z,defs -Wl,-rpath,'$ORIGIN' -shared -L../unxlngi6.pro/lib -L../lib
<snip>
../unxlngi6.pro/slo/nassound.o ../unxlngi6.pro/slo/pasfsound.o
-lvcl680li -lpsp680li -lsot680li -lutl680li -ltl680li -lcomphelp4gcc3
-lucbhelper3gcc3 -luno_cppuhelpergcc3 -luno_cppu -lvos3gcc3 -luno_sal
-lsndfile -lportaudio -laudio -lXext -lSM -lICE -lX11 -ldl -ldl
-lpthread -lm -Wl,-Bdynamic -lstlport_gcc
> ../unxlngi6.pro/slo/saldisp.o: in function « SalDisplay::InitXinerama()      »:

Looks like it's not linking to libXinerama.  Do you have
/usr/lib/libXinerama.so?  Or, /usr/X11R6/lib/libXinerama.so if that's
where X is installed.  For some reason, OO has enabled Xinerama
support in the source (probably through some #ifdef), but it's not
linking in the library with -lXinerama.

--
Dan



More information about the blfs-support mailing list