Xorg 6.8.2 to Xorg 7?

Dan Nicholson dbn.lists at gmail.com
Thu Mar 23 17:31:50 PST 2006


On 3/23/06, Leonardo Lazzaro <lazzaroleonardo at gmail.com> wrote:
>  (I have a LFS 6.1.1 and some packages from BLFS 6.1 )
>  1)If I install Xorg 7 like the instructions in BLFS SVN but with my Xorg
> 6.8.9 already installed could it cause some problems?

I believe you mean you have Xorg-6.8.2 since that's in BLFS 6.1. 
Anyway, there will likely be problems if you follow the instructions
for building Xorg-7 from the book.  You will end up with many files in
duplicate locations.  For instance, files that are now in /etc/X11
with Xorg-6.8.x would be installed in /usr/share/X11 following the
Xorg-7 instructions.

You may have better success installing Xorg-6.9.0.  These are the same
sources used in Xorg-7, but it uses the old monolithic build system. 
What this means is that files will end up in the same location as
Xorg-6.8.x if you use the same host.def file.  For instance, you would
want to install in /usr/X11R6 to overwrite the old libraries.

Possibly, you could install the two versions side-by-side (one in /usr
and one in /usr/X11R6).  That would be pretty adventurous.

Some of the X11 configuration files would have to be fixed, but I
can't say which ones.  I've never tried this.  I'm only guessing, but
I'm considering doing it myself since I have a pretty mature system
with Xorg-6.8.2.

>  2)IF I instal Xorg 7 I have to rebuild some other packages like KDE,QT,etc?

Again, I can't say for sure.  It would be safest to rebuild anything
that links to the Xorg libraries (which are a lot on KDE and QT).

Actually, it would be safest to start from scratch.

>  3)Could i uninstall Xorg 6.8.9 in case i have to do it to install Xorg 7?

You don't have to do it if you install over the top of Xorg-6.8.2.

In either case, you probably shouldn't be running KDE while you're
building Xorg.  Any updated libraries could crash your desktop.

>  Ah! I want to install Xorg 7 to try the Xgl from novell.( or at least try
> it).
>  I have an Ati card with the fgrlx drivers (8.20.8 are the best) so meabe
> someone have already done it. If yes please reply me with the experience.

I don't know anyone here who's tried it.  I'd like to, but I'm a long
ways away.  Maybe someone else could guide you.

--
Dan



More information about the blfs-support mailing list