Xorg 7.0.0 xlogo linking error

Simon Scheiwiller simon at hornweb.ch
Fri Mar 17 05:42:33 PST 2006


Thus spoke Andrew Benton:
> XpuFreeXmbString is defined (on my system) in
> /usr/include/X11/XprintUtil/xprintutil.h (I installed xorg-7 in /usr).
> <X11/XprintUtil/xprintutil.h> is included in xlogo-X11R7.0-1.0.1/print.h
> and "print.h" is included at the top of print.c.
>
> grep -R XpuFreeXmbString /usr

That file is installed:

root at gwaihir:~# ls -l /usr/include/X11/XprintUtil/
total 12
-rw-r--r-- 1 root root 11095 Mar 17 01:01 xprintutil.h

but somehow it can't even be found by find:

root at gwaihir:~# find / -name 'xprintutil.h'
find: /proc/4219/task: No such file or directory
find: /proc/4219/fd: No such file or directory
/usr/include/firefox-1.0.7/xprintutil/xprintutil.h
/usr/include/thunderbird-1.0.6/xprintutil/xprintutil.h
/usr/X11R6/include/X11/XprintUtil/xprintutil.h

> My guess is that your problem may be because you seem to have installed
> xorg into /usr/X11R6, maybe it's having trouble finding
> <X11/XprintUtil/xprintutil.h>?

I installed Xorg-6.8.0 before, and now I'm trying to upgrade to Xorg-7.0.0.
I'll try removing the whole /usr/X11R6 stuff and then installing
Xorg-7.0.0 (and probably reinstalling everything that needs X). Probably
the presence of the old files messed everything up.

> If it's any help, you may not need it. I don't install it and xorg-7
> works fine for me.

I just don't like when I get errors like that, because it indicates that
there could be many more problems coming up.

> --
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page
>
>


-- 
simon scheiwiller
bollstrasse 21
ch-8405 winterthur
+41 78 624 16 73




More information about the blfs-support mailing list