Xorg 7.0.0 xlogo linking error

Simon Scheiwiller simon at hornweb.ch
Thu Mar 16 16:37:31 PST 2006


Hello

I have some problems with compiling xorg 7.0.0 in xlogo-X11R7.0-1.0.1.
XprintUtil is installed, but I get an error while linking to it.

root at gwaihir:/usr/src/blfs/x/xc/app/xlogo-X11R7.0-1.0.1# make
make  all-am
make[1]: Entering directory `/usr/src/blfs/x/xc/app/xlogo-X11R7.0-1.0.1'
if gcc -DHAVE_CONFIG_H -I. -I. -I.    -I/usr/X11R6/include  
-I/usr/X11R6/include -I/usr/include/freetype2
-I/usr/include/freetype2/config     -g -O2 -MT xlogo-Logo.o -MD -MP -MF
".deps/xlogo-Logo.Tpo" \
  -c -o xlogo-Logo.o `test -f 'Logo.c' || echo './'`Logo.c; \
then mv -f ".deps/xlogo-Logo.Tpo" ".deps/xlogo-Logo.Po"; \
else rm -f ".deps/xlogo-Logo.Tpo"; exit 1; \
fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.    -I/usr/X11R6/include  
-I/usr/X11R6/include -I/usr/include/freetype2
-I/usr/include/freetype2/config     -g -O2 -MT xlogo-RenderLogo.o -MD -MP
-MF ".deps/xlogo-RenderLogo.Tpo" \
  -c -o xlogo-RenderLogo.o `test -f 'RenderLogo.c' || echo
'./'`RenderLogo.c; \
then mv -f ".deps/xlogo-RenderLogo.Tpo" ".deps/xlogo-RenderLogo.Po"; \
else rm -f ".deps/xlogo-RenderLogo.Tpo"; exit 1; \
fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.    -I/usr/X11R6/include  
-I/usr/X11R6/include -I/usr/include/freetype2
-I/usr/include/freetype2/config     -g -O2 -MT xlogo-xlogo.o -MD -MP -MF
".deps/xlogo-xlogo.Tpo" \
  -c -o xlogo-xlogo.o `test -f 'xlogo.c' || echo './'`xlogo.c; \
then mv -f ".deps/xlogo-xlogo.Tpo" ".deps/xlogo-xlogo.Po"; \
else rm -f ".deps/xlogo-xlogo.Tpo"; exit 1; \
fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.    -I/usr/X11R6/include  
-I/usr/X11R6/include -I/usr/include/freetype2
-I/usr/include/freetype2/config     -g -O2 -MT xlogo-print.o -MD -MP -MF
".deps/xlogo-print.Tpo" \
  -c -o xlogo-print.o `test -f 'print.c' || echo './'`print.c; \
then mv -f ".deps/xlogo-print.Tpo" ".deps/xlogo-print.Po"; \
else rm -f ".deps/xlogo-print.Tpo"; exit 1; \
fi
gcc  -g -O2   -o xlogo  xlogo-Logo.o xlogo-RenderLogo.o xlogo-xlogo.o
xlogo-print.o -lXaw8 -lXmu -lXt -lX11 -lSM -lICE -lXau   -lXprintUtil -lXt
-lX11 -lSM -lICE -lXp -lXau   -L/usr/X11R6/lib -lXrender -lX11 -lXext  
-L/usr/X11R6/lib -lXft -lX11 -lfreetype -lXrender -lfontconfig   -lXext
xlogo-print.o: In function `FinishPrinting':
/usr/src/blfs/x/xc/app/xlogo-X11R7.0-1.0.1/print.c:132: undefined
reference to `XpuCompoundTextToXmb'
/usr/src/blfs/x/xc/app/xlogo-X11R7.0-1.0.1/print.c:136: undefined
reference to `XpuFreeXmbString'
collect2: ld returned 1 exit status
make[1]: *** [xlogo] Error 1
make[1]: Leaving directory `/usr/src/blfs/x/xc/app/xlogo-X11R7.0-1.0.1'
make: *** [all] Error 2

What's wrong here?

Simon

-- 
simon scheiwiller
bollstrasse 21
ch-8405 winterthur
+41 78 624 16 73




More information about the blfs-support mailing list