Blurred LCD screen on Xorg 7?

Simon Geard delgarde at ihug.co.nz
Fri Mar 10 01:06:25 PST 2006


On Mon, 2006-03-06 at 18:37 +0500, Alexander E. Patrakov wrote:
> Simon Geard wrote:
> > Anyone have any idea what might cause this? The Monitor sections of
> > xorg.conf are the same in both cases, including the modeline that tells
> > it how to do 1920x1200. Device section is the same. Screen section is
> > mostly the same, apart from not specifying Modes for each depth (it
> > defaults to the right resolution without them).
> 
> Try either specifying modes exactly, or putting the following line in 
> the Monitor section:
> 
> VertRefresh 59-61

Ok, that didn't help, but I have found one thing interesting. X thinks
it's running in 1920x1200 as it's been told to - that's the resolution
reported both by xdpyinfo and xrandr. However, at times when the screen
is blurred, the monitor itself is claiming to be running 1600x1200. I
assume the blur then is from the screen being squashed to fit the lower
resolution, then the monitor stretching it out again to fill the screen.

So, anyone have any ideas why, or how to fix it? It's not happening
consistently - sometimes it works fine, and when it doesn't, changing
the resolution to something else and back (with xrandr) seems to shake
it into the correct mode. But that's a real pain...

In case it makes a difference, the monitor is running on VGA input,
since I don't (currently) have a DVI-capable video card. However, VGA
works fine on X 6.8.1, so I assume that's not an issue.

Simon.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20060310/e4c0002e/attachment.sig>


More information about the blfs-support mailing list