gcc-3.4.x make -k check errors

Lup thelupine at punkass.com
Tue Oct 26 16:06:59 PDT 2004


On Tue, 26 Oct 2004 21:13:31 +0100, Ken Moffat wrote:
> 
>  My first guess would be that you don't have a matching binutils.  Try
> building binutils-2.15.9x first (on x86, go with what is in -unstable)
> and install it into e.g. /opt/newtools or /usr/local or wherever you
> want the alternative toolchain.  Then put that at the front of your PATH
> and try again.  Alternatively, --with-{as,ld}=/full/path/to/bin/{as,ld}.
> 
>  An alternative is that maybe expect can't manage the 'spawn ls' test.
> 
>  After that, try logging the output and adding a -v to the configure
> (dunno if -v is helpful, I've just seen it in the gcc test archives).
> Maybe there are more meaningful error messages, so "make -k check >mylog
> 2>&1" to look at the gory detail.
> 
> Ken

I'm just trying to upgrade my existing gcc-3.3.3 to gcc-3.4.x using my LFS
system.  I wanted to have gcc-3.4.x in place before I continue updating
any other part of BLFS.  On my other already existing BLFS laptop, I'm
running gcc-3.3.4 and it too can't upgrade to any version of gcc-3.4.x.  I
always follow the LFS and BLFS book, and install in either /opt/ or /usr/
when instructed.  However, it just won't update to any gcc-3.4.x version. 
Don't know if any of this extra info helps, just wanted to clarify what I
was attempting to do.

Thanks for the tips about logging the "make -k check" output, and checking
on binutils, I'll look into that and see if that gets me any where.

-Lup




More information about the blfs-support mailing list