OpenOffice-1.1.3 build error

S. Anthony Sequeira tony at sequeira.org.uk
Mon Oct 25 15:07:11 PDT 2004


On Mon, 25 Oct 2004 15:40:08 -0600, Archaic wrote:

> So I gave 1.1.2 a try and and get this:
> /usr/bin/ld: cannot find -lXinerama
> collect2: ld returned 1 exit status
> dmake:  Error code 1, while making '../unxlngi4.pro/lib/libvcl645li.so'
> 
> /usr/X11R6/lib/libXinerama.so -> libXinerama.so.1.0
> /usr/X11R6/lib/libXinerama.so.1 -> libXinerama.so.1.0
> /usr/X11R6/lib/libXinerama.so.1.0
> 
> ldd /usr/X11R6/lib/libXinerama.so.1.0
>         libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40009000)
>         libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40018000)
>         libc.so.6 => /lib/libc.so.6 (0x400e2000)
>         libdl.so.2 => /lib/libdl.so.2 (0x40212000)
>         /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
> 
> /etc/ld.so.conf is correct and ldconfig has been run. Unless -lXinerama
> refers to libXinerama.a (whic doesn't exist on my current system), then
> I'm at a loss.

Try this, not sure where I picked it up.

$ cat openoffice-1.1.2-xinerama.patch
--- ./vcl/util/makefile.mk.orig 2004-04-09 09:18:20.000000000 +0200
+++ ./vcl/util/makefile.mk      2004-04-09 18:17:11.000000000 +0200
@@ -299,7 +299,7 @@
 SHL1STDLIBS += -lXp -lXext -lSM -lICE -lX11
 .ELSE
 .IF "$(CPU)" == "I"
-SHL1STDLIBS += -Wl,-Bstatic -lXinerama -Wl,-Bdynamic
+SHL1STDLIBS += -lXinerama
 .ENDIF
 SHL1STDLIBS += -lXext -lSM -lICE -lX11
 .ENDIF          # "$(USE_XPRINT)" == "TRUE"

-- 
Tony

Experience is directly proportional to the cost of the equipment ruined.




More information about the blfs-support mailing list