OpenOffice-1.1.3 build error

Archaic archaic at linuxfromscratch.org
Mon Oct 25 14:40:08 PDT 2004


On Mon, Oct 25, 2004 at 11:12:03AM -0500, Randy McMurchy wrote:
> 
> I know you can build it from an LFS-5.1.1 system (which uses GCC-3.3.3).
> I have not yet tried to build it from an LFS-6.0-testing system and
> GCC-3.3.3.

Hmmmm. If you take the non-toolchain packages from lfs-testing-07152004
and put them on a 5.1.1 toolchain, that is what I'm trying to build on.
The last time I built OOo was on a 5.0 using Xfree-4.2 (IIRC). Trying to
build OOo-1.1.3 gives me this error:

/home/archaic/openoffice-1.1.3/solver/645/unxlngi4.pro/inc/external/boost/detail/atomic_count_linux.hpp:19:39:
boost/detail/linux_atomic.h: No such file or directory

Which indeed does not exist in the source tree. There is no other
reference to this file in the build logs.

So I gave 1.1.2 a try and and get this:
/usr/bin/ld: cannot find -lXinerama
collect2: ld returned 1 exit status
dmake:  Error code 1, while making '../unxlngi4.pro/lib/libvcl645li.so'

/usr/X11R6/lib/libXinerama.so -> libXinerama.so.1.0
/usr/X11R6/lib/libXinerama.so.1 -> libXinerama.so.1.0
/usr/X11R6/lib/libXinerama.so.1.0

ldd /usr/X11R6/lib/libXinerama.so.1.0
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40009000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40018000)
        libc.so.6 => /lib/libc.so.6 (0x400e2000)
        libdl.so.2 => /lib/libdl.so.2 (0x40212000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

/etc/ld.so.conf is correct and ldconfig has been run. Unless -lXinerama
refers to libXinerama.a (whic doesn't exist on my current system), then
I'm at a loss.

-- 
Archaic

"Guard with jealous attention the public liberty.  Suspect every one who
approaches that jewel.  Unfortunately, nothing will preserve it but
downright force.  Whenever you give up that force, you are inevitably
ruined."

- Patrick Henry, speech of June 5 1788




More information about the blfs-support mailing list