OpenOffice-1.1.3 build error

Magnus Larsson magnus.larsson.k at bredband.net
Mon Oct 25 07:55:12 PDT 2004


Nathan Coulson wrote:

> On Sun, 24 Oct 2004 07:53:08 +0200, Magnus Larsson
> <magnus.larsson.k at bredband.net> wrote:
>> Hello blfs dev,
>> 
>> I can not build OpenOffice-1.1.3 from source. Dmake ends with error code
>> 1:
>> 
>> ....
>> reading file /tmp/filej7NajY ....................
>> reading file /tmp/file0hISFQ ....................
>> Generating .rc file
>> error: Resource larger than 64K cannot be handled. Aborting.
>> Error starting rsc2 compiler
>> dmake:  Error code 1, while making '../unxlngi4.pro/bin/sc64591.res'
>> ---* TG_SLO.MK *---
>> 
>> ERROR: Error 65280 occurred while
>> making /source/openoffice/OOo_1.1.3_src/sc/util
>> dmake:  Error code 1, while making 'build_all'
>> ---* TG_SLO.MK *---
>> 
>> I am using:
>> Linux lfs 2.6.8.1 #1 Sat Oct 9 18:39:31 CEST 2004 i686 athlon i386
>> GNU/Linux LFS: Version SVN-20041001 => Glibc-2.3.4-20040828,
>> Binutils-2.15.92.0.2 GCC-3.4.2
>> GCC used for OO build: GCC-3.3.1. I have installed GCC-3.3.1 separately
>> for the OO build.
>> OO-source: OOo_1.1.3-1_source.tar.gz
>> Patches from BLFS svn-20041002:
>> openoffice-1.1.2-test_bin_loc-1.patch
>> openoffice-1.1.2-jdk_1.4.2_fix-1.patch
>> openoffice-1.1.2-domainname-1.patch
>> gpc231.tar.Z
>> 
>> The 1.1.2 patches were accepted by patch and applied to 1.1.3 without any
>> fuzz.
>> 
>> I do know that my LFS base is unstable. However, the unstable LFS
>> SVN-20041001, performs well. I have built QT-3.3.2, Xfree86-4.4.0,
>> KDE-3.3.1 and J2SDK-1.4.2, as well as OpenOffice-1.1.2. I did manage to
>> build and install OpenOffice-1.1.2 from source as per the BLFS SVN
>> instruction without any faults.
>> 
>> I have tried different GCC-3.3.x versions, besides the GCC-3.3.1 i
>> normally use for the OO builds. No change. Dmake ends with an error as
>> listed above.
>> 
>> Questions to blfs.dev:
>> Has anyone managed to build OO-1.1.3? If so, how?
>> What is the difference between OOo_1.1.3-1_source.tar.gz and
>> OOo_1.1.3-source.tar.gz? I have based all build attempts on
>> OOo_1.1.3-1_source.tar.gz.
>> 
>> Best regards,
>> 
>> Magnus Larsson
> 
> I have not successfully build openoffice, but I believe that binutils
> 2.15.92.0.2 will not work.  you need 2.15.91.0.2 or earlier.  [I'm
> playing with binutils 2.15, but I have problems not related to that,
> see blfs-support for more details].
> 
> You should move this thread over to blfs-support if you reply

Hello Nathan Coulson and blfs.support

Binutils:
I have tried installing the older Binutils-2.15.90.0.3 in a
separate /opt/binutils directory, uptating /etc/ld.so.conf and path
accordingly, but that did not work either. I got the same oo-1.1.3 dmake
error. "..Resource larger than 64K cannot be handled. Aborting.
Error starting rsc2 compiler". 
I will revert to a pure Binutils-2.15.90.0.3 system and try and rebuild
again. I am not confident when it comes to setting up parallel Binutils.

However, I did manage to build oo-1.1.2 using the newer Binutils-2.15.92.0.2
and gcc-3.3.1. (I have also built oo-1.1.2 using Binutils-2.15.90.0.3 with
an older CVS LFS as the base system).

Best regards,

Magnus Larsson











More information about the blfs-support mailing list