x.org + GTK + Nvidia driver weird interaction?

Chris Macksey c_macksey at spamSPAMspamitySPAMhotmail.com
Sat Oct 23 08:25:27 PDT 2004


Simon Geard wrote:

> You sure it's the nVidia driver? I've got a setup more or less the same
> as the one you describe on a secondary partition, and I haven't had any
> problems with X, including 3d acceleration. I have seen segfaults from
> other programs on the system though - anything relating to gstreamer
> fails, and I've seen problems with gnome-settings-daemon too. Running
> with gdb didn't point at any consistent point of failure.
> 
> If I remember correctly (haven't used it for a few weeks), the problems
> happened regardless of whether I used the nv or nvidia drivers. I'm
> leaning towards possibly a bug in that particular glibc, since the exact
> same BLFS packages on a slightly older LFS base (3-4 months) works fine.


Well, it all depends on how I want to assign blame :)

* When I run x.org with "nv" instead of "nvidia", everything works, 
including GTK+, but no 3-D (and very slow, of course).
* When I run x.org with "nvidia" and *don't* run any GTK+ apps, 
everything works, including 3D acceleration (so long as I don't have 
xcompmgr running)
* I've tried the combo of Nvidia 5336 and GTK+ 2.4.1, which currently 
works fine on my stable system (with XFree86 4.3) - so the culprit seems 
to be x.org.

Of course, I'm willing to point the blame at glibc, the kernel, 
binutils, or gcc for that matter, if there's any evidence pointing that 
way :)

They do differ between my systems (of course):

New system:
  LFS 6.0 testing (09/29/2004)
  kernel 2.6.8.1
  glibc 2.3.4 08/28/2004 NPTL
     This is the only substitution I made from the book, and only
     under duress - I was having trouble getting the GLibC test
     suite to pass, but it turns out I was having an interaction with
     my host system.  I've subsequently gotten the test suites to
     pass with this GLibC.
  binutils 2.15.91.0.2
  gcc 3.4.1

Current (stable) system:
   "bleeding edge" LFS 5.0 built using a 2.6 kernel and a lot of patches
   kernel 2.6.4 (was originally 2.6.0)
   glibc 2.3.2 linuxthreads
     I didn't quite have the cajones at the time to try getting NPTL
     working :)
   binutils 2.14
   gcc 3.3.1

=================================
Chris Macksey
<c_macksey at DONTspamMEhotmail.com>
=================================



More information about the blfs-support mailing list