x.org + GTK + Nvidia driver weird interaction?

Simon Geard delgarde at ihug.co.nz
Sat Oct 23 04:49:29 PDT 2004


On Fri, 2004-10-22 at 13:33 -0500, Chris Macksey wrote: 
> Hi all, I'm in the process of assembling a LFS/BLFS testing (kernel 
> 2.6.8.1, GCC 3.4.1, NPTL) system (to eventually replace my current LFS 
> system - kernel 2.6.4, GCC 3.3, Linuxthreads).  The LFS portion seems to 
> work perfectly, but I have a bizarre problem in the "Beyond" portions. 
> I'm hoping someone here can point me in the right direction so I can 
> solve the problem.
> 
> Essentially, the threefold combination of x.org 6.8.1 plus GTK+ plus the 
> NVidia binary driver causes X to segfault the moment a GTK+ application 
> is opened.

You sure it's the nVidia driver? I've got a setup more or less the same
as the one you describe on a secondary partition, and I haven't had any
problems with X, including 3d acceleration. I have seen segfaults from
other programs on the system though - anything relating to gstreamer
fails, and I've seen problems with gnome-settings-daemon too. Running
with gdb didn't point at any consistent point of failure.

If I remember correctly (haven't used it for a few weeks), the problems
happened regardless of whether I used the nv or nvidia drivers. I'm
leaning towards possibly a bug in that particular glibc, since the exact
same BLFS packages on a slightly older LFS base (3-4 months) works fine.

Simon.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20041024/2ba5ec52/attachment.sig>


More information about the blfs-support mailing list