x.org + GTK + Nvidia driver weird interaction?

Jeremy Utley jeremy at jutley.org
Fri Oct 22 23:39:38 PDT 2004


Chris Macksey wrote:

> GCZ wrote:
>
>> I do. Although some things probably need to be fixed in the driver, I 
>> have had several issues with certain versions of GTK+. All I can 
>> tell, is that version 2.4.10 of GTK+ is the only one since several 
>> releases that seems to work without problems. That's also the case on 
>> my laptop, which has an i830M graphical chipset and thus doesn't use 
>> nvidia's driver.
>>
>> Try uninstalling GTK+; check that no GTK+ file remains on your system 
>> after 'make uninstall' (I noticed that libgtk-x11-2.0.so* still 
>> remained in /usr/lib sometimes), then build and install version 
>> 2.4.10. It might solve your issues.
>>
>
> Thanks for the suggestion.  Done and done, still getting the X 
> segfaults (I'm getting a little bit *too* intimately familiar with the 
> "Magic SysRq Keys").
>
> On the bright side, I do have to say that 2.4.10 does look much better 
> than the other versions I was using when I use the nv driver.  I was 
> getting weird graphical anomalies (like the triangles on the treeviews 
> looking all mutated and deformed) in all the other versions, but not 
> 2.4.10.
>
> So, at least I'm one tiny step ahead of where I was.
>
> OK, since you actually have it working I have many questions  :D
>
> * What version of the NVidia driver are you using, the latest or an 
> older version?  I've tried both 5336 and 6111, but it would be nice to 
> use one that at least has a chance of working?
> * Are you using AGPGART or NvAGP?
> * What driver options are you passing to the driver in your xorg.conf?
> * Which version of x.org are you using, standard 6.8.1, or something 
> newer?
> * Have you applied any custom patches to x.org?
>
> This thing's going to drive me over the deep end yet, I can tell ;)
>
> =================================
> Chris Macksey
> <c_macksey at DONTspamMEhotmail.com>
> =================================

Everything works just fine for me - to answer your questions, I'm using 
the 6111 version of the Nvidia driver, with Xorg 6.8.1.  The opts I 
passed to X are:

-O2 -fno-strength-reduce -fno-strict-aliasing -march=athlon-xp

I'm using the default configuration file for Xorg as established by X 
-configure, but replacing the nv driver with nvidia, otherwise, it's 
pretty much stock as generated by X-configure.

-J-



More information about the blfs-support mailing list