Missing /dev/fb/0

Ken Moffat ken at kenmoffat.uklinux.net
Fri Oct 22 17:47:04 PDT 2004


On Fri, 22 Oct 2004, Aaron BRICE wrote:

> I am trying to use the "fbdev" device in XF86Config on an LFS
> installation I did a long time ago..  However, when I run it, it
> complains that /dev/fb0 does not exist.  I'm using devfs with kernel
> 2.6.9 options:
> CONFIG_FB=y
> CONFIG_FB_VESA=y
> CONFIG_FB_I810=m
>
> When I boot the system there's just an empty /dev/fb/ directory.  I
> tried to modprobe the i810fb module, which worked, but still no devices.
>   Any advice?  The system is a Dell SX260 which has the integrated i810
> graphics on it.  The i810 driver works in the XF86Config so I know
> that's the correct device, but I need to get the fbdev driver working.
>
> Thanks,
> Aaron
>
>

 mknod (perhaps in a bootscript) ?  If you insist on using devfs with
2.6, it _will_ hurt you eventually.  But, why do you use a module for
the framebuffer ?

 When 2.6 framebuffers first started to work, there were a lot of
complaints from people building more than one of them that they didn't
work properly, and the advice was to build only one of them.  Dunno if
that has changed, but if it hasn't, it might catch you later.

Ken
-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the blfs-support mailing list