x.org + GTK + Nvidia driver weird interaction?

Chris Macksey c_macksey at spamSPAMspamitySPAMhotmail.com
Fri Oct 22 11:33:15 PDT 2004


Hi all, I'm in the process of assembling a LFS/BLFS testing (kernel 
2.6.8.1, GCC 3.4.1, NPTL) system (to eventually replace my current LFS 
system - kernel 2.6.4, GCC 3.3, Linuxthreads).  The LFS portion seems to 
work perfectly, but I have a bizarre problem in the "Beyond" portions. 
I'm hoping someone here can point me in the right direction so I can 
solve the problem.

Essentially, the threefold combination of x.org 6.8.1 plus GTK+ plus the 
NVidia binary driver causes X to segfault the moment a GTK+ application 
is opened.

ORIGINAL SETUP:
* I installed the newest x.org (X11R6.8.1).
* I installed the newest 6111 NVidia binary driver.
* NO GTK+

I altered my xorg.conf to use "nvidia" instead of "nv", turned on 
RenderAccel, and enabled the Composite and Render extensions.   I ran X, 
everything works fine - opened XClock, XEyes, and XTerm (ran it both 
normally and using an Xft Font) - everything works fine, and fast.  Ran 
X both with xcompmgr and without - also fine, and fast.

Installed PekWM as my window manager (which I also use on my stable 
system), and started using it.  Also works fine.

So far, so good.

THEN:
* I installed GTK+ 2.4.9 (in preparation for installing some/most of 
Gnome 2.8.0), together with the prereqs of ATK 1.8.0 and Pango 1.6.0.

After installing, I started X again - again, all is well.  Then, to test 
GTK+, I ran gtk-demo, and... Segfault - together with the video 
glitching so bad I had to use Alt-SysRq-S and Alt-SysRq-B to get out of 
there.  Most of the window came up, though, before the crash - only the 
treeview on the side didn't.

Anyway, I've spent several days already bashing this one about.  Here's 
what I've come up with so far.

* It is definitely the GTK+ treeview that is triggering the problem - I 
can run simple GTK apps that don't have it, and they work fine.  I 
tested a few simple apps with Images, TextViews, splitters, etc., and 
everything seems to work fine.  I added a treeview to the app, and it 
segfaults the moment the treeview is selected.
* It doesn't seem to be related to the theme engine.  I've tried the 
default engine, as well as Ximian's industrial, and they both exhibit 
the same behaviour.
* GTK+ 2.4.1, 2.4.9 and 2.4.13 all exhibit similar behaviour, although 
2.4.1 is more stable with my test programs (although not gtk-demo - I 
suspect this is because it doesn't try to do anything when you select a 
nodeless treeview).
* Nvidia drivers 5336 (with kernel 2.6 patches) and 6111 both exhibit 
the problem.
* The problems go away when I use "nv" instead of "nvidia", although the 
drawing in X is abysmally slow - even without a composite manager.
* the xorg log has nothing in it but the normal startup code (which 
looks fine to me), and then the signal 11 crash.

So, I guess what I'm asking is does anyone have any ideas as to where I 
might go/what I might try from here?  Does anyone have the NVidia binary 
driver, x.org 6.8.1, and GTK+ 2.4.x working together?

I can gladly send any information requested - xorg.conf, build options, 
etc.  I would certainly like to compare mine to those from someone's 
working system.

===============================
Chris Macksey
c_macksey at DONTspamMEhotmail.com
===============================



More information about the blfs-support mailing list