Short questions on DHCP

Ken Moffat ken at kenmoffat.uklinux.net
Fri Oct 22 06:08:42 PDT 2004


On Fri, 22 Oct 2004, D.Moriarty wrote:

> Ken Moffat wrote:
>
> > On Thu, 21 Oct 2004, D.Moriarty wrote:
> >
> >
> >>I've been there and tried most of that. It hangs because I still have
> >>LFS-3.3 and the boot scripts are a little different. I can't be exact
> >
> > Ok, from my firewall which is running something around lfs-3.3 (doesn't
> > seem to have any /etc/lfs-* so I can't be sure of the exact version) and
>
> Glibc-2.2.5? That's probably a good timestamp.

 Definitely.  What I meant was mine might be slightly _older_ than 3.3,
but it's definitely that sort of vintage, not the new-fangled LFS-4 on
my main box :)

> > uses *eth1* for the connection to the world (eth0 for my lan).  Probably
> > very badly done, but working.
> If it's working, Ken, it's not very badly done :-)
> [SNIP scripts]
>
> My system barfs as follows: /etc/sysconfig/network fails to find
> $network_devices; I hacked that, and then it fails to find an IP and
> mentions  ifconfig.eth0. This is bull, as I tried IPs in there. So I

 It's the $network_devices that sounds worrying - maybe permissions on
one or more of the scripts, particularly executable.  All of my ifdown
and ifup scripts are executable, the ifconfig files only need to be
readable.  Or maybe a typo or something else.  My /etc/sysconfig/network
only has HOSTNAME=something in it.

> figured to do it manually. I gather from your scripts you can do it
> manually by
>
> modprobe eth1
> dhclient eth1 -1
>

In your case, s/eth1/eth0/g I think.  The '-1' is optional - this is my
gateway, if it doesn't get an address it might as well give up quickly
(normally means I need to reboot the set-top box, or wait for someone to
sort out the upstream).

 Of course, you need the alias for eth0 in modules.conf (always assuming
the driver is a module).

> Mind you, this is the first outing for the network bootscript, so that
> takes me back to all the mistakes made building my very first lfs :-o.

 Yes, bootscripts on current builds are a lot easier.

> >
> > Note also that for this version of dhclient the leases are in
> > /var/state/dhcp/dhclient.leases and you will need to touch that (or
> > wherever your version is looking) before you can get a lease.
>
> Yeah, the dhclient.leases have their own manpage.
>

 If this doesn't help, can you note the exact error message(s) and
anything else relevant form the kernel or daemon logs ?

Ken
-- 
 das eine Mal als Tragödie, das andere Mal als Farce




More information about the blfs-support mailing list