kdegraphics-3.3.0 does not find imlib-1.9.14

Randy McMurchy randy at linuxfromscratch.org
Thu Oct 14 15:39:25 PDT 2004


<toffi at muenster.de> wrote:
> Hi!
>
> I have spent the last hour, trying to compile kdegraphics-3.3.0 with
> imlib-1.9.14
>
> I first installed imlib (and made sure it got installed) and then tried to
> configure kdegraphics according to the instructions in the blfs-svn-20041014
> book.
> However, kdegraphics would always tell me that I don't have imlib 1.x ("You're
> missing imlib 1.x").
> In the end, it worked if I passed --with-imlib-config=/usr/bin to ./configure.
> /usr/bin was the dir where imlib-config was located.
>
> I'm not a Linux expert - I just thought that maybe there are others with a
> similar problem and you might want to have a look at the issue.

I'm not sure there's really an issue. On one of my recent builds
of kdegraphics-3.3.0, I didn't have to do anything and Imlib was
discovered automatically.

Using nothing but the exact configure line shown in the BLFS book
results in this:

checking for imlib-config... /usr/bin/imlib-config

and checking the make.log shows that it includes -lImlib in the
build. I can use ldd to show that libImlib.so.1 is linked to the
kuickshow binary in /opt/kde/bin.

--
Randy





More information about the blfs-support mailing list