postgresql-7.4.5 does not detect DocBook SGML DTD-3.1 properly

Nico R. n-roeser at gmx.net
Thu Oct 14 03:12:10 PDT 2004


Randy McMurchy wrote:

> Nico R. wrote:
> 
>> After running configure for postgresql-7.4.5 (yes, I know it's not
>> yet in the book, but this may be reproducible with 7.4.3 also), I get
>> the following in config.log:
>>
>> [snip output from the damn OpenSP declaration problem]
>>
>> Well, I don't understand what's going on here. Does anyone else?
> 
> Yes. I'm very familiar with this. The OpenSP declarations in the
> system SGML catalogs cause this.

*AGAIN* those OpenSP declarations? Argh.
IIRC, it was me who hit this problem earlier with another package... I
should have known...

> I think we should dump the OpenSP 
> declarations, but I've asked 3 times on the list and not one person
> has agreed (or disagreed), so I've been hesitant to dump them.

Dump them. We can put them back in if/when necessary or do some other
modifications, like add a big fat warning.

I still don't understand why exactly they are (not) needed, and whether
this is The Right Thing(tm) to do, but without them, everything seems
to work, and with them, everything breaks. So let's remove them until
newer package versions come from upstream, and then re-evaluate if
necessary.


> The solution is outlined on the DocBook-utils page.

That should be removed after the OpenSP declarations are no longer
present in the system SGML catalogs.
-- 
Nico



More information about the blfs-support mailing list