Mozilla 1.6 crashes

AaronL alee at IfA.Hawaii.Edu
Mon Oct 11 19:22:42 PDT 2004


Hi,

I just tried out the precompiled version of Mozilla-1.6 and it doesn't 
crash.  With or with Java / Javascript enabled, my self compiled mozilla 
crashes.  I'm beginning to suspect a problem with the gcc3.3.3 
compiler.  I had another crash, segmentation fault problem with xmms 
when exiting.  The xmms problem went away when I recompiled xmms and 
glib-1.2 with gcc2.95.3.  Recompiling with gcc3.3.3 again still made 
xmms crash. 
Maybe I'll have to see if I can recompile Mozilla with something other 
than gcc3.3.3 to see what happens. 
Without recompiling, I'm attaching the gdb btrace of the crash...

Aaron.

mozilla -g
/usr/lib/mozilla-1.6/run-mozilla.sh -g /usr/lib/mozilla-1.6/mozilla-bin
MOZILLA_FIVE_HOME=/usr/lib/mozilla-1.6
  
LD_LIBRARY_PATH=/usr/lib/mozilla-1.6:/usr/lib/mozilla-1.6/plugins:/usr/lib/mre/mre-1.6
DISPLAY=:0.0
DYLD_LIBRARY_PATH=/usr/lib/mozilla-1.6:/usr/lib/mre/mre-1.6
     
LIBRARY_PATH=/usr/lib/mozilla-1.6:/usr/lib/mozilla-1.6/components:/usr/lib/mre/mre-1.6
       SHLIB_PATH=/usr/lib/mozilla-1.6:/usr/lib/mre/mre-1.6
          LIBPATH=/usr/lib/mozilla-1.6:/usr/lib/mre/mre-1.6
       ADDON_PATH=/usr/lib/mozilla-1.6
      MOZ_PROGRAM=/usr/lib/mozilla-1.6/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
which: no ddd in (./:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin)
/usr/bin/gdb /usr/lib/mozilla-1.6/mozilla-bin -x /tmp/mozargs3995
GNU gdb 6.2.1
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain 
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...(no debugging symbols 
found)...Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) r
Starting program: /usr/lib/mozilla-1.6/mozilla-bin
(no debugging symbols found)...(no debugging symbols found)...(no 
debugging symbols found)...(no debugging symbols found)...[Thread 
debugging using libthread_db enabled]
[New Thread 16384 (LWP 4021)]
[New Thread 32769 (LWP 4025)]
[New Thread 16386 (LWP 4026)]
[New Thread 32771 (LWP 4027)]
[New Thread 49156 (LWP 4028)]
[New Thread 65541 (LWP 4031)]
[Thread 65541 (LWP 4031) exited]
[New Thread 81926 (LWP 4032)]
[Thread 81926 (LWP 4032) exited]
[Thread 32771 (LWP 4027) exited]
[New Thread 98311 (LWP 4082)]
[New Thread 114696 (LWP 4084)]
[New Thread 131081 (LWP 4085)]
[Thread 131081 (LWP 4085) exited]
[Thread 114696 (LWP 4084) exited]
[New Thread 147466 (LWP 4101)]
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 4021)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x41360cc8 in NSGetModule ()
   from /usr/lib/mozilla-1.6/components/libimglib2.so
#2  0x41362f20 in NSGetModule ()
   from /usr/lib/mozilla-1.6/components/libimglib2.so
#3  0x40f9677c in NSGetModule ()
   from /usr/lib/mozilla-1.6/components/libgklayout.so
#4  0x40f9648b in NSGetModule ()
   from /usr/lib/mozilla-1.6/components/libgklayout.so
#5  0x40ffff67 in NSGetModule ()
   from /usr/lib/mozilla-1.6/components/libgklayout.so
#6  0x40f2e38d in NSGetModule ()
   from /usr/lib/mozilla-1.6/components/libgklayout.so
#7  0x41055ecb in NSGetModule ()
   from /usr/lib/mozilla-1.6/components/libgklayout.so
#8  0x41055c20 in NSGetModule ()
   from /usr/lib/mozilla-1.6/components/libgklayout.so
#9  0x4105a46c in NSGetModule ()
   from /usr/lib/mozilla-1.6/components/libgklayout.so
#10 0x415878ad in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#11 0x08d470b0 in ?? ()
#12 0x08a0ff88 in ?? ()
#13 0x00000001 in ?? ()
#14 0x00000034 in ?? ()
#15 0x00000000 in ?? ()
#16 0x415d1b60 in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#17 0xbffff008 in ?? ()
#18 0x41583629 in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#19 0x08d363b8 in ?? ()
#20 0x08a0ff88 in ?? ()
#21 0x00000034 in ?? ()
#22 0xbfffeff0 in ?? ()
#23 0x00000034 in ?? ()
#24 0x415c3f00 in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#25 0x00000000 in ?? ()
---Type <return> to continue, or q <return> to quit---
#26 0x4157109c in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#27 0x00000000 in ?? ()
#28 0x00000000 in ?? ()
#29 0x00000000 in ?? ()
#30 0x00000063 in ?? ()
#31 0x00000001 in ?? ()
#32 0x0000000a in ?? ()
#33 0x00000001 in ?? ()
#34 0x00000000 in ?? ()
#35 0x00000000 in ?? ()
#36 0x415d1b60 in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#37 0xbffff058 in ?? ()
#38 0x415843c9 in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#39 0x08d363b8 in ?? ()
#40 0x083756d0 in ?? ()
#41 0x00000034 in ?? ()
#42 0x08a0ff88 in ?? ()
#43 0x00000000 in ?? ()
#44 0x415d1b60 in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#45 0x00000034 in ?? ()
#46 0x4157af93 in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#47 0x00000000 in ?? ()
#48 0x00000001 in ?? ()
#49 0x00000000 in ?? ()
#50 0x00000000 in ?? ()
#51 0x00000000 in ?? ()
#52 0x00000063 in ?? ()
#53 0x0003000f in ?? ()
#54 0x00000034 in ?? ()
#55 0x08a0ff88 in ?? ()
#56 0x415d1b60 in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#57 0xbffff108 in ?? ()
#58 0x41582abd in ?? () from /usr/lib/mozilla-1.6/components/libhtmlpars.so
#59 0x08d363b8 in ?? ()
#60 0x083756d0 in ?? ()
---Type <return> to continue, or q <return> to quit---
#61 0x00000000 in ?? ()
#62 0x414da412 in nsBaseWidget::AddRef ()
   from /usr/lib/mozilla-1.6/components/libwidget_gtk2.so
Previous frame inner to this frame (corrupt stack?)
(gdb) q
The program is running.  Exit anyway? (y or n) y


DJ Lucas wrote:

> Andrew Benton wrote:
>
>> AaronL wrote:
>>
>>> Hi,
>>>
>>> I'm running Mozilla 1.6 under LFS5.1 and BLFS5.1.  Mozilla crashes 
>>> when I visit www.sis.com and click on the "Products", "Support & 
>>> Download", etc tabs in the webpage.  Is anyone running Mozilla?  Do 
>>> you mind visiting www.sis.com to see if your browser crashes?
>>
>>
>>
>> Works for me (no crash) with Firefox
>> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a5) Gecko/20041010 
>> Firefox/0.9.1+
>
>
> No problems here.  Without the necessary information, I can only make 
> assumtions at the problem.  Site uses java script so that's probably 
> the first place to look.
>
> _Assuming_ both are self compiled, try the binary versions first.  
> Drop back to the binary j2sdk.  If this works, recompile j2sdk without 
> optimizations.  If not, try binary mozzy with your compiled 
> j2sdk...then with the binary plugin.  If all that fails, then I have 
> no idea.  But first I'd try and give a bit more info on the problem to 
> see if anyone else has a better idea.
>
> -- DJ Lucas





More information about the blfs-support mailing list