Xorg compile trouble

Declan Moriarty declan.moriarty at ntlworld.ie
Mon Oct 4 01:20:53 PDT 2004


On Mon, Oct 04, 2004 at 12:05:14PM +0800, Mhac Janapin enlightened us thusly
> Hello guys,
> 
> This is my first post here.
> 
> I just installed my first LFS on an Athlon-XP last Thursday.
> Then the next day, I upgraded to 2.6.8.1-mm2 and udev following the 
> 2.6-udev.txt from the hints page 
> (www.linuxfromscratch.org/hints/downloads/files/2.6-udev.txt) .
> The upgrade went fine.
> 
> Then I downloaded BLFS-BOOK-5.1 and installed several apps, like links. Then I 
> went ahead and prepared to install X on my box. I installed freetype, libpng, 
> fontconfig as preparations. I downloaded the 7 src of X11R6.7.0 and checked 
> their md5sums, which are all OKs. I followed the manual in creating shadow 
> directory in my xcbuild using lndir. Then I created the config/cf/host.def in 
> my xcbuild directory as per manual instructions. 
> 
> My problem was with the building step.
> When I issue the command
> # (make World 2>&1 | tee xorg-compile.log && exit $PIPESTATUS )
> 
> I got error messages. Here's the xorg-compile.log

This seems to be the error.

> Makefile.proto:91: *** commands commence before first target.  Stop.


You did take a peek with vim, didn't you? Vim +91 Makefile.proto
What it seems to be complaining about is a command commencing before the
target, which is like an instruction beginning before the start of a
subroutine. Mebbe it's misinterpeting something?

BTW, it's always a good idea to mention at least your gcc version. 
Typically, everything compiled by a 'new gcc release' needs patches before it 
will work, and a lot of errors come from here. 
-- 

	With best Regards,


	Declan Moriarty.



More information about the blfs-support mailing list