Update: ppp-2.4.2 (kinda solved)

Yann E. MORIN yann.morin.1998 at anciens.enib.fr
Sun Feb 29 23:51:25 PST 2004


Hi!

Once upon a time (on Monday 01 March 2004 05:18), DJ Lucas wrote :
 > Yann E. MORIN wrote:
 > > Plugin pppoe.so loaded.
 > The plugin is actually "rp-pppoe.so" but that message could be left over
 > from a previous version.

pppoe.so is a softlink to rp-pppoe.so and is a left over of a previous
experimentation (I kept the unpatched-by-me .so around and would switch
to test, using the link to point to the correct .so).

 > eth0 a module, and if so, did you modprobe it first?  Try actually
 > giving it an if-up and if-down first maybe also.

eth0 loaded OK. ifconfig -a shows eth0 eth1 and lo. Will try if-{up,down}
first.

OK. It works now. But eth0 was to be configured _and_UP_. What does
that imply, eth0 to be up? Is it a security hole, or what? What I don't
get, is that the last time I connected, I am pretty sure eth0 was DOWN,
and that it worked. Anyway, eth0 : 10.0.0.1/24 made the trick.

 > Is it by chance still looking at the old plugin?  Plugin dir is
 > /usr/lib/pppd/2.4.2/ as opposed to the old /etc/ppp/plugins/.

No /etc/ppp/plugins. That one was made by RP-pppoe, which I promptly
removed a long time ago (time when in-kernel pppoe and ppp-2.4.2 were
working OK, even after I removed RP-pppoe).

Thanks very much for your attention,
Yann.

-- 
.-----------------.--------------------.-------------------------------.
|  Yann E. MORIN  | Real-Time Embedded | /"\   ASCII RIBBON            |
| +0/33 662376056 | Software  Designer | \ /     CAMPAIGN           ^  |
| --==< °_° >==-- °---.----------------:  X    AGAINST HTML        /e\ |
| web: ymorin.free.fr | SETI at home 3178 | / \  IN MAIL & NEWS       """ |
°---------------------°----------------°-------------------------------°
 \__ np:  [Stopped] __________________________________________________/




More information about the blfs-support mailing list