loading modules

Albert alwagner at tcac.net
Thu Feb 26 20:39:40 PST 2004


OK. My current problem has a better solution.  I'm still not sure I
understand why.  Nevertheless, thanks to all who replied.  Your comments
were all useful. Resolution:

(1) Removed the hdc=[scsi|ide-scsi] kernel option from the grub
menu.lst.
(2) Added the following from CD Writing HOWTO to /etc/modules.conf:
options ide-cd ignore=hdc         # tell the ide-cd module to ignore hdc
alias scd0 sr_mod                    # load sr_mod upon access of scd0
pre-install sg     modprobe ide-scsi # load ide-scsi before sg
pre-install sr_mod modprobe ide-scsi # load ide-scsi before sr_mod
#pre-install ide-scsi modprobe ide-cd # load ide-cd   before ide-scsi

(3) Nothing worked until the last line was commented out.  I don't have
an ide-cd module.

--------------------------------------------
$ mount -tiso9660 /dev/scd0 /mnt/cdrom
mount: block device /dev/scd0 is write-protected, mounting read-only
$ ~
$ lsmod
Module                  Size  Used by    Not tainted
sr_mod                 12016   2  (autoclean)
ide-scsi                8720   1 
scsi_mod               88616   2  (autoclean) [sr_mod ide-scsi]
cdrom                  28416   0  (autoclean) [sr_mod]
--------------------------------------------
Executing X-CD-Roast to read a cd gives the same, except it loads
sg
ide-scsi
scsi_mod

-- 
"Don't you see that the whole aim of Newspeak is to narrow the range of
thought? In the end we shall make thoughtcrime literally impossible,
because there will be no words in which to express it."
    -- George Orwell as Syme in "1984"



More information about the blfs-support mailing list