Can't compile aRts-1.2.10

Thomas Paricaud thomas.paricaud at tele2.fr
Thu Feb 26 11:31:41 PST 2004


Gregory Davis wrote:

> Type "ldd /path/to/libqt-mt.so" and tell us what it shows.  There should
> be a line about the relocation of the Xrendr library like:
> libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0x409db000).
> Check and make sure it is valid.

Here is the output of the command :

# ldd /opt/qt/lib/libqt-mt.so
        libpng.so.3 => /usr/lib/libpng.so.3 (0x4084d000)
        libz.so.1 => /lib/libz.so.1 (0x4087d000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x4088f000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x408f9000)
        libdl.so.2 => /lib/libdl.so.2 (0x40921000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x40924000)
        libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x40975000)
        libm.so.6 => /lib/libm.so.6 (0x40a2c000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x40a4e000)
        libc.so.6 => /lib/libc.so.6 (0x40a56000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x40b70000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

I didn't want to recompile qt because it takes a very long time but I will
do it anyway.


> As an aside, I had some funny errors trying to compile kde 3.2 and qt 3.3
> that resolved themselves by regressing to qt 3.2.

I have at the same time problems for compiling gnome and I'd like to see if
these errors are not linked before thinking of regressing to qt-3.2.

Thank you for your help.
Thomas



More information about the blfs-support mailing list