xkbcomp and error loading libXext.so.6 and libX11.so.6

zorrk zorrk.nospam. at gazeta.pl
Wed Feb 25 15:10:02 PST 2004


Hello
My's sytem is LFS 5.0
The problem is that when I starting X ,get (in short ) xkbcomp can't load
libXext.so.6 .That library is in /usr/X11R6/lib

[root at hokum root]# ls -al /usr/X11R6/lib/libXext.*
-rw-r--r--    1 root     root        72216 Sep 16 22:15 /usr/X11R6/lib/libXext.a
lrwxr-xr-x    1 root     root           14 Feb 25 20:11 /usr/X11R6/lib/libXext.so -> libXext.so.6.4
lrwxr-xr-x    1 root     root           14 Feb 25 20:11 /usr/X11R6/lib/libXext.so.6 -> libXext.so.6.4
-rwxr-xr-x    1 root     root        53688 Feb 21 20:03 /usr/X11R6/lib/libXext.so.6.4


I have correct right to that directory 
root at hokum root]# ls -al /usr/X11R6/
total 24
drwxr-xr-x    6 root     root         4096 Feb 25 20:11 .
drwxr-xr-x   13 root     root         4096 Feb 25 19:15 ..
drwxr-xr-x    2 root     root         4096 Feb 25 20:11 bin
drwxr-xr-x    7 root     root         4096 Feb 25 20:11 include
drwxr-xr-x    7 root     root         4096 Feb 25 20:11 lib
drwxr-xr-x    7 root     root         4096 Feb  2 00:02 man


I have that library path in ld.so.conf 
[root at hokum root]# cat
/etc/ld.so.conf
   /usr/local/lib
   /usr/X11R6/lib
   /usr/local/qt/lib
   /opt/kde/lib
#   /usr/lib/X11/


Looks normal but it's not working

When I startx on root everything IS OK (!!!) ,but not on users.
 I was thinking that is Xfree is bad -I take Xfree from slackware 9.1
 ...and the same way....

And xkbcomp is "see" libXext.so.6 (but  was not before instaling xfree
from slackware 9.1)  

[zorrk at hokum zorrk]$ ldd
/usr/X11R6/lib/X11/xkb/xkbcomp
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40016000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40025000) libc.so.6
        => /lib/libc.so.6 (0x400f3000) libdl.so.2 => /lib/libdl.so.2
        (0x40223000) /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
(this is library from xfree compiling by me..)
Before xfree from slackware 9.1 was 

ldd /usr/X11R6/lib/X11/xkb/xkbcomp
        libXext.so.6 => not found
        libX11.so.6 => not found
(but xkbcomp was  not report  any errors with libX11.so.6)
        libc.so.6 => /lib/libc.so.6 (0x4001e000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

If i am right libXext.so.6 and xkbcomp is needed for polish (in my case)

Any ideas??
Similar problem is with vmware before and after slackware xfree 
vmware for any users (root and other) report 

[zorrk at hokum zorrk]$ vmware
/usr/lib/vmware/bin/vmware: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such file or directory

And like before 
[root at hokum root]# ls -al /usr/X11R6/lib/libX11*
-rw-r--r--    1 root     root      1357404 Sep 16 22:15 /usr/X11R6/lib/libX11.a
lrwxr-xr-x    1 root     root           13 Feb 25 20:11 /usr/X11R6/lib/libX11.so -> libX11.so.6.2
lrwxr-xr-x    1 root     root           13 Feb 25 20:11 /usr/X11R6/lib/libX11.so.6 -> libX11.so.6.2
-rwxr-xr-x    1 root     root       816264 Feb 21 20:03 /usr/X11R6/lib/libX11.so.6.2

Vmware is VERY important to me ......
Pliz help me ...
Sorry for me english ....
-- 

Andrzej"zorrk"Kazuk
gg:1598332



More information about the blfs-support mailing list