Can't compile aRts-1.2.10

David Jensen djensen at inebraska.com
Wed Feb 25 08:44:16 PST 2004


Thomas Paricaud wrote:

>Hi everybody,
>
>Since I can't compile gnome, I decided to compile KDE for the moment but I
>get this error in config.log when configuring aRts-1.2.10 :
>
>configure:29351: checking for Qt
>configure: 29422: /opt/qt/include/qstyle.h
>taking that
>tried NO
>configure:29534: rm -rf SunWS_cache; g++ -o conftest -Wnon-virtual-dtor
>-Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi
>-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion
>-Wchar-subscripts -DNDEBUG -DNO_DEBUG -O2 -Wformat-security
>-Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common
>-I/opt/qt/include -I/usr/X11R6/include  -DQT_THREAD_SUPPORT  -D_REENTRANT 
>-L/opt/qt/lib -L/usr/X11R6/lib   conftest.cc  -lqt-mt -lpng -lz -lm -ljpeg
>-ldl  -lXext -lX11 -lSM -lICE  -lpthread 1>&5
>/opt/qt/lib/libqt-mt.so: undefined reference to `XRenderCompositeString8'
>/opt/qt/lib/libqt-mt.so: undefined reference to `XRenderCompositeText32'
>  
>

The linker is not finding libXrender.  Do you have
/usr/X11R6/lib in your /etc/ld.so.conf ?
if not add it, and /opt/qt/lib, then:
]#ldconfig -v

David Jensen




More information about the blfs-support mailing list