Evolution 1.4.4 and 1.4.5 crash on startup (workaround)

Ricardo Barberis richis at lfs-es.org
Wed Feb 25 06:41:42 PST 2004


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi everyone,

I just finished compiling Evolution but am having problems when trying to 
run it:

[richis at plfs-es ~] $ LANG=C evolution

(evolution:21873): libglade-WARNING **: Could not load support for `gnome': 
libgnome.so: cannot open shared object file: No such file or directory

(evolution:21873): libglade-WARNING **: unknown widget class 'GnomeDruid'

(evolution:21873): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to 
`GnomeDruid'

(evolution:21873): GnomeUI-CRITICAL **: file gnome-druid.c: line 865 
(gnome_druid_set_buttons_sensitive): assertion `GNOME_IS_DRUID (druid)' 
failed

(evolution:21873): GLib-GObject-WARNING **: gsignal.c:1893: signal `cancel' 
is invalid for instance `0x812ae08'

(evolution:21873): evolution-shell-CRITICAL **: file 
e-shell-startup-wizard.c: line 803 (e_shell_startup_wizard_create): 
assertion `data->start != NULL' failed

Google only shows a couple of false positives, a message on a RedHat list 
and this one from this list: 
http://linuxfromscratch.org/pipermail/blfs-support/2003-July/038351.html

Anyway, the guilty one seems to be libglade but I don't know how to properly 
fix this. In my system, I have GNOME 2.4 (BLFS-CVS from December 03 or 
January 04, I can check if needed) in /opt with some libglade files 
installed into /opt/gnome-2.4/lib/libglade/2.0.
So I took "the easy way out" and just ln -s'd them to /opt/gnome-2.4/lib and 
after running ldconfig Evo came to life (yipiee!!).

Of course I'll be testing it, so if anyone has anything to say please speak 
and avoid my system's destruction :-)

Cheers.
- -- 
Ricardo Barberis
Usuario Linux Nº 250625:           http://counter.li.org
Usuario LFS Nº 5121:               http://www.linuxfromscratch.org
LFS en castellano:                 http://www.lfs-es.org
Senior SysAdmin - Dattatec.com - Hosting Solutions
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQFAPLQmnabpmElFaJkRAsLGAKCEHp4xVAGhmNMqtwVfmL/QVSM3MwCdGeyT
K1DayHkd3kJKNlMtLy/tdUk=
=MBM6
-----END PGP SIGNATURE-----




More information about the blfs-support mailing list