A2ps goes belly up

Declan Moriarty declan.moriartyt at ntlworld.ie
Sat Feb 21 06:40:38 PST 2004


I have an LFS-3.3 here which worked fine with gs-7.05. I have updated to
8.10, and some months/years later I finally noticed a2ps is going belly up
every time I run it.  To be precise, gs throws the error, in print on
the printer:

Error: /typecheck in --transform--

Operand stack:
	latin1dict	fCourier  --nostringval--  --nostringval--
Execution stack:	
	(usual nonsense)



Dictionary stack:
	dict:1110/1686(ro)(G)  --dict: 0/20(G) &similar 

The seat of my posterior informs me that it's a problem with the way gs
invokes gs. I did check for fonts - a2ps uses it's own, and I did back
it down to level1 postscreipt which reduces the fonts used.

GS prints fint through the PFS hint script, mozilla, OO, Opera, Abiword,
and I think I actually got something through vim also. I have this for
GS_FONTPATH
genius:~$echo $GS_FONTPATH
/usr/local/share/AbiSuite/fonts/:/usr/local/share/a2ps/fonts/:/home/genius/OO/share/fonts/truetype/:/usr/share/groff/1.17.2/font/devps/:/usr/X11R6/lib/X11/fonts/freefont/:/usr/X11R6/lib/X11/fonts/Type1/

a2ps-4.10.2 BTW

Any ideas??
-- 

	With best Regards,


	Declan Moriarty.



More information about the blfs-support mailing list