QT won't build... Segmentation fault @ qmake_image_collection.cpp

Alexander E. Patrakov semzx at was.at.newmail.ru
Mon Feb 23 08:31:37 PST 2004


R. Bosch wrote:

> Hi,
> 
> I tried to compile qt-3.3.0 by the book. I have a system based on LFS-CVS.
> Other programs are:
> X430.1src.tar.bz2 + XFree86-4.3.0-bool.patch
> nas-1.6.tar.bz2 (patched)
> libmng-1.0.6.tar.bz2
> 
> gcc-3.3.2.tar.bz2
> glibc-2.3.3-20031202.tar.bz2

You forgot to apply the POSIX version patch to ch5 and ch6 coreutils. As a
result, your gcc is flawed, it thinks that gas has no ".hidden" directive. 

Unfortunately, this means that everything you have is miscompiled. You have
to start from scratch.

-- 
Alexander E. Patrakov



More information about the blfs-support mailing list