still trying to get kernel pppoe to work

Tom Haller tom.haller at att.net
Fri Feb 20 12:08:46 PST 2004


Hello again,

Does anyone know of another news group or mailing list which might address ppp/pppoe problems? Maybe I'll have better luck there. In the mean time, sadly, I'm dead in the water; I'm afraid all the time and effort I spent building this system may be for nothing (except that I learned a good deal along the way, which is not nothing).

The last thing I tried was bringing up inetd, which I copied over from Debian as it does not seem to be in either LFS of BLFS, unless I missed something. Does ppp need inetd? In any event, it didn't help.

Tom
> Hi all,
> 
> I'm still trying to get kernel-mode pppoe to work on my LFS/BLFS system. 
> Everything seems set up correctly and I get no error messages when I run "pppd 
> eth0", but nothing happens. When I run XP on the same box, I can connect with no 
> problem. When running LFS, I can connect to another box using static IP and a 
> cross-over cable.
> 
> I posted a question about this last week but never got any responses. In the 
> mean time I've scoured news groups & web, including this list's archive, and 
> tried many variations, but haven't found the solution yet. I'm hoping someone 
> might suggest what to do next or where else I could look for help. I do 
> appreciate any help, even a hint. I'm getting desperate! :-(
> 
> My /etc/ppp/options file (I've tried a number of variations):
> 
> user 12341234 at worldnet.att.net
> local
> lock
> sync
> debug
> plugin rp-pppoe.so
> connect /bin/true
> ipcp-accept-remote
> ipcp-accept-local
> usepeerdns
> noipdefault
> defaultroute
> hide-password
> nocrtscts
> noauth
> mru 1492
> mtu 1492
> lcp-echo-interval 10
> lcp-echo-failure 3
> 
> My chap-secrets:
> 12341234 at worldnet.att.net * mypassword 0.0.0.0
> 
> >From my kernel config:
> CONFIG_PPP=y
> CONFIG_PPP_ASYNC=y
> CONFIG_PPP_SYNC_TTY=y
> CONFIG_PPP_DEFLATE=y
> CONFIG_PPP_BSDCOMP=y
> CONFIG_PPPOE=y
> 
> >From daemon.log:
> pppd[100]: Plugin rp-pppoe.so loaded.
> pppd[100]: RP-PPPoE plugin version 3.3 compiled against pppd 2.4.2
> pppd[101]: pppd 2.4.2 started by root, uid 0
> pppd[101]: send (sendPacket)
> 
> ifconfig eth0 output (same before and after running "pppd eth0"):
> eth0      Link encap:Ethernet  HWaddr 00:0B:DB:02:AA:AA  
>           BROADCAST MULTICAST  MTU:1500  Metric:1
>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:100 
>           RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
>           Interrupt:11 Base address:0xec80 
> 
> Thank you!
> 
> Tom
>  
> -- 
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page



More information about the blfs-support mailing list