Vorbis libraries on LFS 5.1?

Simon Geard delgarde at ihug.co.nz
Sun Feb 15 01:34:08 PST 2004


Alexander E. Patrakov wrote:

> Simon Geard wrote:
> 
> > The package and all related libs (libao/ogg/vorbis) all compiled and
> > installed without any errors - however, when I try to play something
> > with ogg123, it outputs the file metadata, then exits with the
> > rather blunt message "Killed". No sound is produced.
> 
> Can't reproduce this on my NPTL-enabled LFS (ALSA drivers from
> linux-2.6.1, userspace libs are 1.0.2, the soundcard is ABIT AU10,
> FM801-based).
> 
> Could you please specify your audio hardware and drivers?

Actually, I found the problem on my own. I was using the 1.0 series ALSA
libs package, having gotten the impression from this fragment from the
ALSA documentation that these libraries were compatible with the 0.9
series:

:   ALSA library has a copy of kernel header files and it
:   is backwards compatible with ALSA code 0.9 final (which
:   is also in the 2.6 kernel tree). In other words, you can
:   use 1.0 packages without any problems.

Apparently, that means only that the newer library package will work
fine with the 0.9 series drivers (such as those currently in the 2.6
kernels) - it doesn't mean the 1.0 series libraries will work with
existing code based on 0.9. A nasty gotcha.

I realised the problem when I tried upgrading to newer versions of the
vorbis libs - libao-0.8.3 compiled against the newer alsa libs, but
0.8.4 didn't (SDL had the same problem). Once I downgraded to
0.9 libs, things worked fine. I assume that while the older libao
compiled against the new alsa libs, it was missing some initialisation
code.

Simon.



More information about the blfs-support mailing list