Vorbis libraries on LFS 5.1?

Simon Geard delgarde at ihug.co.nz
Sat Feb 14 02:40:34 PST 2004


Bit of a puzzle here. I've just completed an LFS build more or less
equivalent to the 5.1 prerelease, but I'm running into some odd issue
with the ogg123 program included with vorbis-tools.

The package and all related libs (libao/ogg/vorbis) all compiled and
installed without any errors - however, when I try to play something
with ogg123, it outputs the file metadata, then exits with the
rather blunt message "Killed". No sound is produced.

Audio is working fine on the machine - aplay can play wav files, and if
I chroot into my old system (LFS 5), the copy of ogg123 there works
fine. Conversely, if I chroot into the new system from the old, the
program doesn't work.

Any ideas? I don't have anything else installed yet that can play
vorbis (system is pretty minimal so far), but if no one has any ideas,
I'll try installing xmms or something, and see if that works...

Simon.



More information about the blfs-support mailing list